Closed Bug 295105 Opened 19 years ago Closed 19 years ago

marquee detect wrong mouse action

Categories

(Core :: DOM: Events, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 53007

People

(Reporter: nicecherub, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When mouse move to the margin of marquee component
The image being move for a littel distance
Wrong mouse action being detected

Reproducible: Always

Steps to Reproduce:
<marquee id=xiaoqing onmouseover=xiaoqing.stop() onmouseout=xiaoqing.start()
style="PADDING-RIGHT: 0px; PADDING-LEFT: 0px; BACKGROUND-ATTACHMENT: scroll;
PADDING-BOTTOM: 0px; PADDING-TOP:0PX BACKGROUND-REPEAT: "repeat scrollAmount= 5
direction=up width=150 height=200>
<img src=http://img.photobucket.com/albums/v625/sidrakollers/love2.gif width=150
height=150 />
<img src=http://samueltai.mine.nu/photos/albums/yooni/IMG_5061.thumb.jpg
width=150 height=113 /></span><br /><span id="profExpertise"><b>Expertise:</b>
</span><span id="profExpertise1"><img
src=http://samueltai.mine.nu/photos/albums/yooni/IMG_5063.thumb.jpg width=150
height=113 />
<img 
src=http://samueltai.mine.nu/photos/albums/people/IMG_4890.thumb.jpg width=150
height=200 />
<img 
src=http://samueltai.mine.nu/photos/albums/people/IMG_4896.thumb.jpg width=150
height=113 />
<img src=http://samueltai.mine.nu/photos/albums/5yr4a/IMG_5429.thumb.jpg
width=150 height=113 />
<img src=http://samueltai.mine.nu/photos/albums/dolls/IMG_0187.thumb.jpg
width=150 height=113 />
<img src=http://samueltai.mine.nu/photos/albums/RCTVHangs/IMG_5755.thumb.jpg
width=150 height=113 />
</marquee>
Actual Results:  
The image do not move if the mouse inside the marquee
Assignee: nobody → events
Severity: minor → normal
Component: General → DOM: Events
Keywords: testcase
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk
Attached file Testcase
Seing this as well with a trunk build (20050521) on win XP.

Steps to reproduce
1. Load testcase and wait for it to start scrolling
2. Hover it and it will stop, mouseout and it will continue to scroll
3. Now hover the text "Expertise" when it comes, it will stop, when you move
the mouse down, still within the marquee, onmouseout will be triggered

*** This bug has been marked as a duplicate of 53007 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: