Remember open pages/tabs after a crash

VERIFIED DUPLICATE of bug 159357

Status

()

Firefox
General
--
enhancement
VERIFIED DUPLICATE of bug 159357
12 years ago
12 years ago

People

(Reporter: Adam Nielsen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050226 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050226 Firefox/1.0.1

It would be nice if Firefox stored the URLs of all open tabs on the filesystem
somewhere and updated it every time a tab/window is opened/closed, so that if it
crashes (or the computer does, or there's a power outage, etc.) when you get
back in and reload Firefox all the pages you were looking at can be restored.

There should also be an popup along the lines of "There were multiple tabs open
when Firefox was last running, do you want to open them again? Yes/No" so that
if it's a bad web page causing a crash you can just choose "No" and start fresh
- you don't want Firefox crashing again every time it is reloaded.

Reproducible: Always

Steps to Reproduce:
1. Load some web pages
2. Run "killall firefox"
3. Load firefox and note that the previously loaded web pages have gone.

Actual Results:  
All the previously opened tabs have disappeared.

Expected Results:  
Asked me whether I wanted to restore my previously open tabs, and if I agree,
then opened all the tabs I had running in step #1.

*** This bug has been marked as a duplicate of 159357 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.