[Modern]The horizontal scroll bar at the bottom of the window does not show the triangular arrows.

REOPENED
Unassigned

Status

()

Core
Layout
REOPENED
13 years ago
11 years ago

People

(Reporter: roy, Unassigned)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050521
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050521

Looking at any web page that has table content wider than the current
browser window causes a horizontal scroll bar to appear at the bottom
of the window. The end of the scroll bar should display triangles that
point right and left. This version of Mozilla does not show the triangles;
they previously did appear correctly. Also, in the space near where the
triangles should appear, there may be a lot of garbage vertical lines where
the scroll bar should be.

Reproducible: Always

Steps to Reproduce:
1. go to www.netscape.com
2. resize the browser window to be narrower than the Netscape page
3.

Actual Results:  
The scroll bar appears at the bottom of the screen, but the triangles
are missing. Also, there are extra lines in the scroll bar space
near where the triangles should be.

Expected Results:  
The triangles should appear, and there should be no extra vertical lines
in the space near where the triangles should be, it should be filled
with a solid dark gray color as seen in the vertical scroll bar.

Comment 1

13 years ago
This only occurs in the Modern theme. The "garbage" between the scrollbar and
the corners looks like some repainting issue - it might already been filed,
since i think it's been there for a while. Hmm, atm I can't figure out what
changes have caused this... Nothing in the theme files looks suspicious, must be
something else.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: The horizontal scroll bar at the bottom of the window does not show the triangular arrows. → [Modern]The horizontal scroll bar at the bottom of the window does not show the triangular arrows.

Comment 2

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050522

Both horizontal and vertical scrollbars are OK for me (using both modern and
classic on a new profile).  So probably Mac only.

Comment 3

13 years ago
OK, guessing Core: Layout.

Updated

13 years ago
Component: General → Layout
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk

Comment 4

13 years ago
Created attachment 184325 [details]
Screenshot of the issue

The repainting issue seems to be new as well.

Updated

13 years ago
Assignee: general → nobody
QA Contact: general → layout

Comment 5

13 years ago
Could bug 240276 have caused this? Guessing that the arrow not showing is
obscured by bug 292312 until that was fixed, the issue doesn't seem to be there
in 2005042710.
probably not me...

Comment 7

13 years ago
roc, it seems that the repainting issue was caused by your checkin in bug 240276
(2005-04-28 14:57). The repainting issue is there in a build I made from a
checkout with -D "2004-04-28 1500 PDT". Backing out the patch in bug 240276
makes it go way. The arrows are there as well, but the cause of missing arrows
needs some more investigation.
*** Bug 299467 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
Hmm, It looks like the arrows disappeared at the same time... Here's my
observations:

No arrows in a build from 2005-04-28 23:30 PDT with the patch from bug 292312
(changes in layout/generic/nsGfxScrollFrame.cpp) applied.

That would make a regression range (for the arrows disappearing) of:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-04-28+14%3A56%3A00&maxdate=2005-04-28+23%3A09%3A00&cvsroot=%2Fcvsroot

No arrows if I back out the checkins made 2005-04-28 16:47-48 and 15:03-15:17

Updated

13 years ago
Flags: blocking1.8b4?

Updated

12 years ago
Flags: blocking1.8b4? → blocking1.8b4-

Comment 10

12 years ago
KaiRo, not really a 1.0a blocker, but perhaps a 1.0b blocker?

Comment 11

12 years ago
(In reply to comment #10)
> KaiRo, not really a 1.0a blocker, but perhaps a 1.0b blocker?

Did any changes happen to location of the arrow images on mac or something like
that?

Actually, we need to look into it, but I don't think a minor look (not feel)
problem in modern (which is not the default theme) blocks a developer-testing
release such as Alpha. Beta perhaps, yes. Please try to investigate and remind
us for beta.

Comment 12

12 years ago
I haven't seen this for a very long time now. So, it looks like wfm. Anyway, it would be nice if some other mac user can confirm that the issue is gone.

Karsten, can you confirm this (wfm)?

Comment 13

11 years ago
Created attachment 255394 [details]
repainting on SM1.1

Comment 14

11 years ago
(In reply to comment #13)
> Created an attachment (id=255394) [details]
> repainting on SM1.1
> 
..... but not visible on Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a3pre) Gecko/20070214 SeaMonkey/1.5a

Comment 15

11 years ago
This has been fixed by bug 355299
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355299

Comment 16

11 years ago
ugh. sorry.

Wanted to mark this at a different bug.


Is this bug still seen, or has it been fixed on trunk already?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.