Last Comment Bug 295191 - Japanese fonts use fake bold font instead of the according real bold fonts
: Japanese fonts use fake bold font instead of the according real bold fonts
Status: RESOLVED WORKSFORME
:
Product: Core Graveyard
Classification: Graveyard
Component: GFX: Mac (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.asahi.com
: 326059 (view as bug list)
Depends on: atsui
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-23 01:08 PDT by Kilian Muster
Modified: 2009-01-22 10:17 PST (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
blurriness on macupdate.com (23.50 KB, image/jpeg)
2005-05-23 08:49 PDT, Echidnae
no flags Details

Description Kilian Muster 2005-05-23 01:08:26 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050522 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050522 Camino/0.8+

<b> and <strong> tags etc. in Japanese text are rendered using "fake" bold (the
text is copied 4 times in 4 directions) this gives the font a very smudged look,
which makes the Japanese rather unreadable, because of its thin lines. It would
be much more appropriate to have Camino use an according Japanese font to
display the bolded characters..

This has to do with a specific issue with Japanese fonts, since in most cases a
"bold" font is not considered being a bold variation of one "normal" font, but
appears in the font panel as a separate font. Therefore the "bold version" of
e.g. "Hiragino Kaku Gothic Pro W3" would be "Hiragino Kaku Gothic Pro W6", and
accordingly the "bold version" of "Hiragino Mincho Pro W3" is "Hiragino Mincho
Pro W6".

Also Japanese fonts are displayed with Roman Names in OS X, so this has to be
considered when fixing this bug. The Japanese font names are only used when the
OS is switched to Japanese.

Reproducible: Always

Steps to Reproduce:
1. Open Japanese website, with bolded fonts
2. See how ugly it is
3. ?? profit ??

Actual Results:  
The Japanese bolded text was pretty hard to read and ugly.

For whatever reason, no profit.

Expected Results:  
Beatifully rendered fonts using the bolder W6 font instead of applying fake bold.
Comment 1 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-05-23 02:18:12 PDT
Does Firefox do the right thing?  I'm not qualified to tell if Firefox gets it
right or not.

I think I've seen a core bug about this subject, but it may well be the "use
ATSUI" bug, too.
Comment 2 Kilian Muster 2005-05-23 02:23:30 PDT
(In reply to comment #1)
> Does Firefox do the right thing?  I'm not qualified to tell if Firefox gets it
> right or not.
> 
> I think I've seen a core bug about this subject, but it may well be the "use
> ATSUI" bug, too.

Actually Firefox doesn't render bolded Japanese text properly either.
Comment 3 Echidnae 2005-05-23 08:49:01 PDT
Created attachment 184320 [details]
blurriness on macupdate.com

This is not just a problem with Japanese fonts.  I've been getting this on
macupdate.com too, although I've been told that it looks worse on my powerbook
compared to other screens.
Comment 4 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-07-22 21:44:46 PDT
In bug 972(!) Greg K indicates that support for real bold variations needs
ATSUI; leaving this a separate bug but making it depend on ATSUI.  Since this
affects Firefox, too, moving to Core.

I can't reproduce comment 3, but comment 0 seems pretty clear (fuzzy text!) to
me now.

Reporter, a couple of screenshots (Camino/Firefox and a browser that gets it
right (Safari?)) would be helpful, too.
Comment 5 Boris Zbarsky [:bz] 2005-07-28 20:06:59 PDT
Doesn't sound like a layout problem, folks.
Comment 6 Kilian Muster 2006-01-24 04:24:29 PST
With Japanese fonts the issue is even more complex, because they usually don't have a "bold" font style as part of one font file. The most common way of distinguishing the "boldness" of a Japanese font is the ending of the font name. So e.g. "Hiragino Kaku Gothic W3" would be a regular font and "Hiragino Kaku Gothic W6" would be bold.

I am not a programmer, but I do have the feeling that there must be some Cocoa hooks for doing the bolding just right without really thinking about the font name. Safari e.g. does it properly and all other Cocoa apps I know as well (not only browsers). When you switch your environment to Japanese in OS X some of the Japanese font names do change their name to something in Japanese, so the recognition whether a Japanese font is bold or not is not in the actual name, I guess.
Comment 7 Smokey Ardisson (offline for a while; not following bugs - do not email) 2006-02-06 01:56:27 PST
*** Bug 326059 has been marked as a duplicate of this bug. ***
Comment 8 Cody 'codeman38' Boisclair 2006-05-31 22:14:03 PDT
This isn't just an issue with Japanese fonts, but with any font in which the individual styles are installed as separate font files.

I have Bitstream Vera installed as individual TTF files (vera.ttf, verab.ttf, etc.) rather than as a Mac-native suitcase, and the Carbon API sees it as four separate families rather than four styles of the same family (and thus uses artificially generated bold, italic, etc.)  This behavior can also be seen, for instance, in MS Word.
Comment 9 Smokey Ardisson (offline for a while; not following bugs - do not email) 2008-03-27 23:14:47 PDT
This should be WFM on the trunk now (and if it's not, it needs to be moved to Gfx:Thebes).
Comment 10 philippe (part-time) 2008-03-28 00:36:30 PDT
Yeah, the Japanese fonts (Hiragino Kaku Gothic and Hiragino Mincho) now use the real bold face (Cairo + atsui). And the code for synthesising bold/italics for those fonts that lack bold/italic faces has been extensively rewritten (in bug 364713).

If there are fonts that still have display issues on Gecko 1.9, new bugs should be filed.

--> WFM

Note You need to log in before you can comment on or make changes to this bug.