[FIXr]Tab title different from window title on initial load at gmail

VERIFIED FIXED in mozilla1.8beta3

Status

()

defect
P1
normal
VERIFIED FIXED
14 years ago
a month ago

People

(Reporter: martijn.martijn, Assigned: bzbarsky)

Tracking

({fixed-aviary1.0.5, fixed1.7.9, regression})

Trunk
mozilla1.8beta3
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.7.9 +
blocking-aviary1.0.5 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
Load gmail, you have to be logged in to see the bug.
My window title says: Gmail - Inbox (867)
My tab title say: Gmail
Gmail is doing some kind of redirect I guess, so I think the tab title is still
the title from the redirect.

Does work in 2005-04-28, does not work in 2005-05-29:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-04-28+05%3A00%3A00&maxdate=2005-04-29+10%3A00%3A00&cvsroot=%2Fcvsroot
I suspect this is a regression from the fix for bug 289940.

Comment 1

14 years ago
Hm, I get a similar problem. If I go to a folder (like All Mail), and open a
message, the tab and window show the subject, but if I then click the "Back to
All Mail" link only the window updates.

Comment 2

14 years ago
Where's my mannors, I'm using this build:
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050531
Firefox/1.0+
Posted patch FixSplinter Review
Assignee: general → bzbarsky
Status: NEW → ASSIGNED
Attachment #184977 - Flags: superreview?(jst)
Attachment #184977 - Flags: review?(jst)
(Assignee)

Updated

14 years ago
Priority: -- → P1
Summary: Tab title different from window title on initial load at gmail → [FIX]Tab title different from window title on initial load at gmail
Target Milestone: --- → mozilla1.8beta3
Priority: P1 → --
Target Milestone: mozilla1.8beta3 → ---
(Assignee)

Updated

14 years ago
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → mozilla1.8beta3
Comment on attachment 184977 [details] [diff] [review]
Fix

r+sr=jst
Attachment #184977 - Flags: superreview?(jst)
Attachment #184977 - Flags: superreview+
Attachment #184977 - Flags: review?(jst)
Attachment #184977 - Flags: review+
Comment on attachment 184977 [details] [diff] [review]
Fix

Requesting 1.8b3 approval.  This makes tab titles work right again...
Attachment #184977 - Flags: approval1.8b3?
(Assignee)

Updated

14 years ago
Summary: [FIX]Tab title different from window title on initial load at gmail → [FIXr]Tab title different from window title on initial load at gmail
(Reporter)

Updated

14 years ago
Depends on: 296399
(Reporter)

Updated

14 years ago
Blocks: 296399
No longer depends on: 296399
Comment on attachment 184977 [details] [diff] [review]
Fix

a=dveditz
Attachment #184977 - Flags: approval1.8b3? → approval1.8b3+
Flags: blocking1.7.9+
Flags: blocking-aviary1.0.5+
*** Bug 296399 has been marked as a duplicate of this bug. ***
Fixed for 1.8b3
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 9

14 years ago
We need to get this onto the Aviary branch if you want it for 1.0.5.
Flags: blocking1.7.9?
Flags: blocking1.7.9+
Flags: blocking-aviary1.0.5?
Flags: blocking-aviary1.0.5+
Flags: blocking1.7.9?
Flags: blocking1.7.9+
Flags: blocking-aviary1.0.5?
Flags: blocking-aviary1.0.5+

Comment 10

14 years ago
Comment on attachment 184977 [details] [diff] [review]
Fix

Let's get this landed on the branches as well! a=jay
Attachment #184977 - Flags: approval1.7.9+
Attachment #184977 - Flags: approval-aviary1.0.5+

Updated

14 years ago
Whiteboard: need branch landing
trunk patch had a conflict on merge, this is the branch version of the patch
that I landed on the 1.7.9 and Aviary 1.0.1 branches
tested and landed on branch on bz's behalf, since I'm pretty certain he won't be
landed things any time soon
Whiteboard: need branch landing
verified fixed using 200506170x-1.0.5 firefox builds on linux fc3 and mac os x
10.4.1. when I login to gmail, both the tab title and browser window title are
correctly labeled with "Gmail - Inbox (x)" (replace "x" with the number of new
messages, of course).
Status: RESOLVED → VERIFIED
(In reply to comment #13)
> verified fixed using 200506170x-1.0.5 firefox builds on linux fc3 and mac os x

Since this fixes a regression from bug 289940 and that one hasn't landed on the
aviary branch yet a branch verification is premature.

Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.