Hiding elements from JavaScript doesn't work for first time

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Michal Margula, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I created simple HTML that when you move your mouse over a component it shows
other one (kind of expanding tab, sample will be attached to that bugreport).
Problem is that when moving mouse out of are, onmouseover gets executed, but
only for second time. First time it doesn't work as expected.

Please note that attached testcase.html is stripped HTML, but fully functional.

Reproducible: Always

Steps to Reproduce:
1. Open tetscase.html
2. Move your mouse over text "MOVE YOUR MOUSE HERE..."
3. You will see tab expanding.
4. Now move your mouse out of that area by using dashed lines.
5. Move in via dashed lines.
6. Move out once again.

Actual Results:  
Hides area after step 6, but it should after step 4. Works fine under Opera and
Konqueror.

Expected Results:  
What happens in step 6 (hiding area) should really happen in step 4.
(Reporter)

Comment 1

13 years ago
Created attachment 184361 [details]
Testcase

Comment 2

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050517
Firefox/1.0+

I saw the 'hiding' after step 4.

You might want to check with a more recent build - a nightly.
(Reporter)

Comment 3

13 years ago
Thats true. Works fine on nightly. Sorry for making trouble.
I see the described behaviour with Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
I do not see the described behaviour with Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.8b2) Gecko/20050524 Firefox/1.0+ ID:2005052403
Marking RESOLVED WFM as per this and per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.