Closed Bug 295295 Opened 15 years ago Closed 14 years ago

a form on one side of the page in a div makes links on the other side of the page unclickable

Categories

(Toolkit :: Form Manager, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 102695

People

(Reporter: scottjunk, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

http://scott.connerly.net/blog/comment.php?post=330
It seems to have to do with form elements and links. It is that the form on the
right of this page in a div makes links on the left unclickable that share y
coordinates.  Links on the left that are farther down the screen don't have that
problem

Reproducible: Always

Steps to Reproduce:
um, put the form in a div in the right side of the table.  have links in a div
in the left side of the table.
Actual Results:  
it can't be clicked on

Expected Results:  
be clicked on...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050524
Firefox/1.0+ ID:2005052403
I see this too
Attached file Example HTML
It doesn't so much have to do with forms and links as it does with absolute
positioning and z-index: since you don't specify z-index on anything, and you
have the form and the links stacked on top of each other, the one that comes
last in the source is on top of the earlier one. You can't click the links
because you are just clicking on the empty parts of the div containing the form.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
Should Mozilla really keep you from clicking on a link just because it is on a
lower layer??  I don't think so.  Yes, I was able to resolve my page with this
(thank you Phil!!) but I think this issue still deserves to be reviewed by at
least one more person-

the question at hand: should text/links on lower z-indexes really be
un-selectable and un-clickable?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.