Only want certain people being able to modify TARGET MILESTONE

RESOLVED WONTFIX

Status

()

Bugzilla
Administration
--
enhancement
RESOLVED WONTFIX
13 years ago
4 years ago

People

(Reporter: Howard, Unassigned)

Tracking

(Depends on: 1 bug)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: 

I do not want everyone who has permissions to enter a bug to be able to 
manipulate the target milestone on the main page.  I would like only a certain 
number of people.  How does that get done?

Reproducible: Always

Steps to Reproduce:
1. Enter bug or open bug
2. No matter who you are you can change the target.
3.

Actual Results:  
Target changes and messes up the project management

Expected Results:  
Only allowed certain people.

Comment 1

13 years ago
do you want these less empowered people to be able to reassign bugs?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> do you want these less empowered people to be able to reassign bugs?
Yes.  I do not want anyone to touch the target milestone if they are not in a 
certain group.
Lowering to enhancement because it's possible to locally customize such
behaviour by modifying CheckCanChangeField in process_bug.cgi (see docs section
5.3 (http://www.bugzilla.org/docs/tip/html/cust-change-permissions.html) and
http://groups.google.com/groups?hl=de&lr=&q=restricting+editing+bug&btnG=Suche&meta=group%3Dnetscape.public.mozilla.webtools).
Severity: critical → enhancement

Comment 4

13 years ago
see also bug 71520
Depends on: 90619
OS: Windows XP → All
Hardware: PC → All

Updated

10 years ago
Depends on: 372017
No longer depends on: 90619
I would strongly suggest that this option be available on a per-product basis (as suggested by LpSolit in bug #90619 comment #15).

The use case is obvious: you have 2 independent products, each with their own project manager.  The PM for product A has no business setting milestones on product B (and vice-versa).

I guess it could be similar to the current per-product privs (canconfirm, editbugs, editcomponents), but right now that's a static list defined in the constant PER_PRODUCT_PRIVILEGES.
There is a hook now called bug_check_can_change_field that an admin can use to do this in an extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.