XML Parsing Error when using Tools -> Themes or Tools -> Downloads

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: s_jagadish, Unassigned)

Tracking

1.7 Branch
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.8) Gecko/20050523 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.8) Gecko/20050523 Firefox/1.0.4

I get these errors (below) when I try to use the Extensions & Downloads options
in the Tools menu. My Firefox version is 1.0.4. I have installed the Flashgot exten

XML Parsing Error: undefined entity
Location: chrome://mozapps/content/extensions/extensions.xul?type=themes
Line Number 18, Column 34:        orient="vertical" title="&extensions.title;"
statictitle="&extensions.title;"
---------------------------------^

XML Parsing Error: undefined entity
Location: chrome://mozapps/content/downloads/downloads.xul
Line Number 17, Column 34:        orient="vertical" title="&downloads.title;"
statictitle="&downloads.title;"
---------------------------------^

Reproducible: Always

Steps to Reproduce:
1. Start up Firefox and go to the Tools menu. Select Downloads
2. Start up Firefox and go to the Tools menu. Select Themes
3.

Actual Results:  
I get box with an error as mentioned in the "Details" section.

Expected Results:  
Should have allowed me to check the downloads window or the themes list.
Do you use a build from Mozilla.org or from somewhere else ?
(Reporter)

Comment 2

14 years ago
I built it from FreeBSD ports. I'm running it on FreeBSD 4.10
(Reporter)

Comment 3

13 years ago
Is there an update on this bug? I continue to get this error with Firefox 1.0.5 as 
well.
The problem is, that only you got this problem !
I know a couple of people running their own builds from FreeBSD ports without
this problem. Something must be different in your build environment but what
exactly is impossible to say from here. You could probably manually add the
files that appear to be missing and I suspect you could get help with fixing
your build from http://forums.mozillazine.org/index.php
(Reporter)

Comment 6

13 years ago
I have this problem with Firefox 1.0.6 as well. I tried removing the .mozilla/firefox/
<my profile identifier> directory and restarting firefox. It just exits with a 
Segmentation Fault! I will check with MozillaZine forums for help.
Version: unspecified → 1.0 Branch
Any luck with this? I suspect that the freebsd ports work... have you tried them?
(Reporter)

Comment 8

13 years ago
Thanks, like I mentioned, my firefox *is* built from ports. The problem persists :(
I should have been clearer... I was wonderring about the packages
ftp://ftp.freebsd.org/pub/FreeBSD/ports/packages/www/ - if they don't have this
issue then it would narrow down the cause to either the build environment or the
src files supplied by the freebsd ports
I took the packaged build of Firefox 1.0.6 from freebsd ports, extracted the
files, replaced toolkit.jar and en-US.jar in a linux 1.0.6 build with the
freebsd ones I downloaded, and the extension manager worked as expected. The
extension manager js and xul code for the ui is in toolkit.jar and the locale
files that can cause these types of errors are in en-US.jar. Can you try doing
the same or using the packaged version of 1.0.6 from freebsd ports?
Reporter - have you tried what is stated in comment #10 ?
This is WFM using the FreeBSD ports from 
ftp://ftp.freebsd.org/pub/FreeBSD/ports/packages/www/

I suspect it is something in your build environment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.