Closed Bug 295347 Opened 17 years ago Closed 16 years ago

duplicate entry when drags & drops between two Personal Address Books (PAB)

Categories

(Thunderbird :: Address Book, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: laurent.bauvens, Assigned: Bienvenu)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla Thunderbird 1.0.2 (Windows/20050317)

When you want to create lists in an PAB with same entry coming from another PAB
or ldap directory, this entry appears as many times in the PAB than lists with it.

Reproducible: Always

Steps to Reproduce:
1.Create 2 PAB (PAB1 & PAB2)
2.Create an entry in PAB1 (john.doe@dummy.org)
3.Create 2 empty lists in PAB2 (L1 & L2)
4.Drag & drop the entry john.doe from PAB1 to PAB2/L1
5.Drag & drop the entry john.doe from PAB1 to PAB2/L2


Actual Results:  
john.doe appears twice in PAB2

Expected Results:  
john.doe appears once in PAB2

This bug makes the PAB messy and makes users crazy.

In this case, it's very difficult to explain them how to use efficiently the PAB. 

So this is an important bug because it creates some distrust opposite Thunderbird.

Remark: PAB is a major function in corporate area. It must work with an high
reliability before any large enterprise deployment.

Thanks.
Mark, has this been fixed on the trunk?
David, this isn't fixed yet, I think there's some bugs around that are possibly
duplicates/related - it could be a similar effect to some of the collected
address problems.
confirming, AFAIK it isn't a dup, build id version 1.0+ (20050713) - linux.

I bet it may be related to bug 134590, just permanent in this case.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Assignee: mscott → bienvenu
Version: unspecified → Trunk
this is happening because nsAbMDBDirectory::DropCard doesn't check if the card
already exists, and explicitly adds the card to both the db and the list. The
list checks if the card exists, but the db doesn't. I'm not sure we need to add
the card to the db at all - I think adding the card to the list should add it to
the db already, but I'l check that.
Attached patch proposed fixSplinter Review
the main change is in nsAbMDBDirectory.cpp, most of the rest is cleanup.
Attachment #189463 - Flags: superreview?(mscott)
Attachment #189463 - Flags: superreview?(mscott) → superreview+
Attachment #189463 - Flags: review?(bugzilla)
Comment on attachment 189463 [details] [diff] [review]
proposed fix

r=me
Attachment #189463 - Flags: review?(bugzilla) → review+
Attachment #189463 - Flags: approval1.8b4?
Attachment #189463 - Flags: approval1.8b4? → approval1.8b4+
*** Bug 272996 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.