missing string resources when opening a PHP file from the filesystem

RESOLVED DUPLICATE of bug 290829

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 290829
13 years ago
13 years ago

People

(Reporter: Ian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050517
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050517

Browsing to a PHP file directly from the filesystem produces a dialog (as is
appropriate) with incorrect text.  See the attached screen shot.

Reproducible: Always

Steps to Reproduce:
1. Create a PHP file that contains nothing but the <?php ... ?> processing
instruction
2. Browse to it from a file:// url

Actual Results:  
The dialog appears as in the screen shot

Expected Results:  
The dialog should have appeared, but with more appropriate text.

Here's a PHP file that produces the same output as my PHP file:

<?php

class Foo() {
    public function outputHTML() {
        return "<div>some html</div>";
    }
}

$t = new Foo();

echo $t->outputHTML(), "\n";

?>
(Reporter)

Comment 1

13 years ago
Created attachment 184418 [details]
Picture of dialog box with missing string resources

Forgot to add this along with original report.
(In reply to comment #1)
> Forgot to add this along with original report.

You couldn't have added it along with the original report :-)


Any messages in the javascript console (Tools|Web Development|JavaScript console)?

(Reporter)

Comment 3

13 years ago
> Any messages in the javascript console (Tools|Web Development|JavaScript console)?

Yes.  Several of these:

Error: _timer is not defined
Source File: file:///usr/lib/mozilla/components/nsHelperAppDlg.js
Line: 381

After one of these:

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIURI.userPass]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
file:///usr/lib/mozilla/components/nsHelperAppDlg.js :: anonymous :: line 242" 
data: no]

arg, bug 290829 didn't make it in for 1.7.8 :/

*** This bug has been marked as a duplicate of 290829 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.