From-Header decoded wrong

RESOLVED DUPLICATE of bug 254519

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 254519
13 years ago
13 years ago

People

(Reporter: imphil, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Thunderbird version 1.0.2 (20050317)

I recently got a mail with a from-header looking like that:

From: =?iso-8859-1?Q?Fr=FCndt=2C_Joana?= <Joana.Fruendt@xx.de>

The name should read "Fründt, Joana", but Thunderbird fails to decode the space
correctly and to take it as one name, it splits it up at the space which leads
to odd results, e.g. when replying, or when the sender-address is displayed.

Reproducible: Always

Steps to Reproduce:
1. Get a e-mail with such a from-header ;-)
Actual Results:  
1. In the window where all the e-mails in that folder are listed (usually at the
top-right), the name is displayed in the "Sender"-column as "Fründt".
2. In the window displaying the e-mail (usually at the right-bottom), it's
displayed as "Joana <Joana.Fruendt@xx.de>".
3. When replying to that mail, there will be two To: headers, one saying
"Fründt", the other one saying "Joana <Joana.Fruendt@xx.de>".

Expected Results:  
for 1: It should read "Fründt, Joana"
for 2 and 3: It should read "Fründt, Joana <Joana.Fruendt@xx.de>"

The mail was produced by MS Exchange (X-MimeOLE: Produced By Microsoft Exchange
V6.5.7226.0), so I don't know for sure if the name in the from-header should
have been surrounded by quotes, like it's usually done with spaces in the name,
or if that is not neccessary if it's encoded like it is done here. So it may be
a bug of exchange, but i just tested it with Horde IMP (a webmail program), and
it displays it correctly, so i would assume it's a Thunderbird bug.

Comment 1

13 years ago
Related to bug 292008?

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.