If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

empty/invisible items shown on right-click context menu

RESOLVED INVALID

Status

()

Firefox
Menus
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Pink Ink, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

If I right-click somewhere on a page, I get a context menu with empty or
invisible entries.
I counted from 4 to 14 empty entries. 14 is quite annoying, because some useful
visible items may be located off-screen due to this bug.

Some hints:
The number of invisible entries varies.
The invisibles are one after each other, no other visible items in between.
The position seems to be always the same depending where you right-click.
When right-clicking above text, the invisibles are always between "Select All"
and the spacer above "View Page Source"
When right-clicking in enter-text-field, the invisibles are always between
"Select All" and "Flashblock Options".
When right-clicking on a link, the invisibles are always between "Allow Flash
from this site" and the spacer above "Properties".


Reproducible: Always

Steps to Reproduce:
Just right-click anywhere on the page and on any page.

Actual Results:  
The context menu holds emtpty/invisible items.

Expected Results:  
Display a context menu without empty/invisible items.

Theme:
- Doodle Classic 1.5.9.4
Extensions:
- AddBookmarkHere 1.5.3
- AutoHide 0.9.8
- Bandwidth Tester 0.4.2
- Dictionary Search 0.8
- Download Statusbar 0.9.2
- Flashblock 1.2.9
- Knowledge Fractal 2.1.0
- Magpie 3.1.2
- Session Saver.2 0.2.1.025
- TabX 0.5
- All-in-One-Gestures 0.13.4
- Adblock v5 d2 * nightly 39
(Adblock cannot be the cause of the problem. It was installed lately, after
having seen the bug already)
(Reporter)

Comment 1

13 years ago
Created attachment 184455 [details]
Screenshots of the buggy context menu
start in -safemode and see if the problem still exists
if so, it's one of your extensions that is incompatible with 1.0.4
(Reporter)

Comment 3

13 years ago
Context menu is fine in safe mode, so it must be an extension.
What's the fastest way to find out, which extension it is?
Can they somehow be temporarily disabled one by one?

Comment 4

13 years ago
Resolving invalid per comment 3.

Please use forums, not bugzilla for support questions. You can't disable all
extensions quickly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.