Closed Bug 295437 Opened 15 years ago Closed 15 years ago

Text caret disappears when enclosed in an absolutely positioned div placed over a div with overflow:auto set.

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 223239

People

(Reporter: icnec, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

The caret div disappears for the text input in the following example:
<div id=div1 style="position:absolute"><input type=text></div>
<div id=div2 style="height:400px;width:400px;overflow:auto;"></div>

When the position attribute for div1 is cleared then the caret shows up.  Or 
if the overflow attribute for div2 is removed or set to "overflow:clip" the 
caret appears as well.  So there must be some buggy interaction between 
overflow:auto and dealing with layers on top of things that have the 
overflow:auto attribute set.

Reproducible: Always

Steps to Reproduce:
1. <div id=div1 style="position:absolute"><input type=text></div>
   <div id=div2 style="height:400px;width:400px;overflow:auto;"></div>

Actual Results:  
see Details

Expected Results:  
see Details
Related to/duplicate of Core bug 223239?
yes, looks like a dupe, please reopen if you disagree

*** This bug has been marked as a duplicate of 223239 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.