Deer Park needs to run once after install (1.0.4 didn't)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: kenta, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050524 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050524 Firefox/1.0+

When installing from a nightly tarball, if firefox 1.1 isn't allowed to run
once with write permissions to the install directory, much unhappiness results:
The menubar doesn't display, the menu headings get reduced to transparent chunk
of Times-Roman text in the upper left corner of the screen, the frame and status
bar don't
display, the page content sometimes flashes but is mostly transparent to the
desktop background image.

1.0.4 did not have this behavior.


Reproducible: Always

Steps to Reproduce:
knoppix@ttyp1[knoppix]$ rm -fr ~/.mozilla
knoppix@ttyp1[knoppix]$ wget
'http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-1.0+.en-US.linux-i686.tar.gz'
knoppix@ttyp1[knoppix]$ tar xzf firefox-1.0+.en-US.linux-i686.tar.gz
knoppix@ttyp1[knoppix]$ chmod -R a-w firefox
knoppix@ttyp1[knoppix]$ firefox/firefox
*** loading the extensions datasource
*** Item Installed via directory addition to Install Location: app-global
ItemID: {972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** Item Installed/Upgraded at Install Location: app-global Item ID:
{972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** loading the extensions datasource
*** ... success, item is compatible
Actual Results:  
Firefox is entirely unusable, with display problems described above.  The only
way to quit is CTRL-C.

Expected Results:  
Following the steps above, but with the 1.0.4 tarball (not installer tarball)
doesn't have the display problems.  Firefox starts and displays normally.

Restoring write access makes everything happy again.

knoppix@ttyp1[knoppix]$ chmod -R u+w firefox/
knoppix@ttyp1[knoppix]$ firefox/firefox

The other workaround is to use the "*installer.tar.gz" tarball, which forces
firefox to run once after the install, after which write access may be
taken away and there are no problems.

Comment 1

14 years ago
not installer
Component: Installer → General
QA Contact: installer → general
Version: unspecified → Trunk

Updated

14 years ago
Whiteboard: DUPEME

Comment 2

14 years ago
*** Bug 296698 has been marked as a duplicate of this bug. ***
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.