Closed Bug 295444 Opened 15 years ago Closed 15 years ago

allow installation of extensions once

Categories

(Firefox :: General, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 252830

People

(Reporter: matthijs.wensveen, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

It would be nice to allow FireFox to install an extension from a site that is
not allowed to install extensions. This would preferably be done by clicking on
the toolbar that says "To protect your computer, FireFox prevented ..blah blah"
and selecting "Allow [extension file.xpi] to install".
Just like it is possible to allow a popup to show, without allowing the _entire_
site to show popups.


Reproducible: Always

Steps to Reproduce:
1. Go to the URL
2. Click on the toolbar
3.

Actual Results:  
Nothing

Expected Results:  
Show a menu (or some other GUI) that allows me to install the extension without
having to grant the entire site permission to install any extension, always.

*** This bug has been marked as a duplicate of 252830 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Summary: [rfe] allow installation of extensions once → allow installation of extensions once
You need to log in before you can comment on or make changes to this bug.