non-breaking space ignored between input tags

VERIFIED WORKSFORME

Status

()

Firefox
General
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: frantisek holop, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050522 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050522 Firefox/1.0.4

the non-breaking space html entity is not honoured between <input> tags.  see
steps to reproduce for an example.

Reproducible: Always

Steps to Reproduce:
1. put in a html file: <input type="text" size="64">&nbsp;<input type="text"
size="64">
2. view it and resize the window so it's smaller than the entries side by side
3.

Actual Results:  
the inputs are broken up into 2 lines

Expected Results:  
the inputs should have remained on 1 line, scrollbars should appear for navigating
(Reporter)

Comment 1

13 years ago
Created attachment 184495 [details]
a simple testcase

Updated

13 years ago
Keywords: testcase
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050525
Firefox/1.0+ ID:2005052508

WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

13 years ago
i am not a firefox guru, but i think 1.0+
is not the same line as 1.0.x

does this make my report void?

i am fairly sure that it does not work on 1.0.x including 1.0.4
that's the official version from getfirefox.com so i don't
get it. why did you close the report?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
The 1.0.x series use a very old version of Gecko, and all subsequent releases
will be based on a newer rendering engine. That means that bugs that do not
appear on the trunk are no longer useful.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 5

13 years ago
Hmm, I can reproduce this in:

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050525 Firefox/1.0+

Not sure if it's expected/correct behaviour or not but the inputs definitely wrap.

Can someone else please test with a nightly?

Comment 6

13 years ago
Verifying invalid, not WFM. HTML 4.01 9.3.2.2 says nbsp is for prohibiting a line break between two *words*, not two arbitary elements. Thus it is only applicable within text.

To properly prohibit the line break in this case, wrap the two inputs in an element with the CSS rule white-space:nowrap.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> Verifying invalid, not WFM. HTML 4.01 9.3.2.2 says nbsp is for prohibiting a
> line break between two *words*, not two arbitary elements. Thus it is only
> applicable within text.
> 
> To properly prohibit the line break in this case, wrap the two inputs in an
> element with the CSS rule white-space:nowrap.

mostly interesting.  thanks for clearing this up.
(what is "WFM"?)
WFM = Works For Me
You need to log in before you can comment on or make changes to this bug.