Closed Bug 295501 Opened 17 years ago Closed 17 years ago

Middle-clicking the 'Go' button should load the typed URI in a new tab

Categories

(Firefox :: Toolbars and Customization, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 279687

People

(Reporter: djcater+bugzilla, Unassigned)

Details

Latest-trunk

After typing a URL into the location bar, middle-clicking the Go button should
load up the URL into a new tab.

Reproducible: Always

Steps to Reproduce:

1. Type a URL in the location bar.
2. Middle-click the Go button.

Actual Results:

Nothing happened. The URL was not loaded in the current tab, nor was a new tab
opened.

Expected Results:

A new tab should have been opened loading the typed URL.

Notes: Bug 295498 relates to middle-clicking autocomplete entries. Bug 227826
relates to what happens to the URL in the current tab (not the new one that is
opened,) when Alt + Enter is pressed with a URL in the location bar.

*** This bug has been marked as a duplicate of 279687 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.