crash when middle-click-scrolling an .xml web page [@ nsXBLPrototypeBinding::Init]

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Brad Murray, Unassigned)

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050523 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050523 Firefox/1.0+

Normally, when middle clicking and dragging on a webpage, you should get the
round scrolling icon under the cursor and and be able to scroll the webpage by
moving up or down with the mouse. However, on .xml files, upon middle clicking,
firefox.exe crashes. It works fine on normal pages, just not on this xml page.

Reproducible: Always

Steps to Reproduce:
1. Go to this webpage -> http://planet.mozilla.org/rss20.xml
2. middle click and hold
Actual Results:  
dialog came up notifying me firefox.exe has crashed

Expected Results:  
should scroll nicely

this occured on a fresh clean install of the deer park alpha 1 release canidate
available here: http://weblogs.mozillazine.org/asa/archives/008197.html
(Reporter)

Updated

13 years ago
Summary: crash when viewing an rss web page on middle-click scrolling → crash when viewing an .xml web page on middle-click scrolling
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050525
Firefox/1.0+ ID:2005052509
I see the crash as described too. Tools > Options > Advanced > General >
Autoscroll must be ticked.
Keywords: crash

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is a regression too, as it doesn't happen in Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
However, with 1.04 bug 215762 happens.
Keywords: regression
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050525
Firefox/1.0+ ID:2005052508

confirming, TB doesn't even show up (is present in this build)
This crash happens with the URL the reporter provided
- http://planet.mozilla.org/rss20.xml

but does not happen with this URL
- http://www.extensionsmirror.nl/peter6/firefoxfeed.xml
Works for me, using both links. Strange.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050525
Firefox/1.0+
TBID TB6129664W
Summary: crash when viewing an .xml web page on middle-click scrolling → crash when middle-click-scrolling an .xml web page [@ nsXBLPrototypeBinding::Init]
Created attachment 184553 [details]
testcase from reporter's URL

Updated

13 years ago
Keywords: testcase

Updated

13 years ago

Updated

13 years ago
Attachment #184553 - Attachment mime type: application/vnd.mozilla.xul+xml → text/html

Updated

13 years ago
Attachment #184553 - Attachment is obsolete: true
(Reporter)

Comment 8

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050523
Firefox/1.0+

Tried at home using windows xp and hit bug 215762 but no crash. something is
wrong that is making firefox crash on 2k and simply kills all the formatting on xp.

Comment 9

13 years ago
No crash using latest-trunk on XP, although I do come across the "autoscroll
breaks prettyprint" bug.
(Reporter)

Comment 10

13 years ago
Tried using firefox 1.0.4 at work (Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4) and got behaviour similar to
comment 30 on bug 215762.

https://bugzilla.mozilla.org/show_bug.cgi?id=215762#c30

Comment 11

13 years ago
firefox crashed and the center scroll button when pressed no longer scrolled
webpages, on any tab.
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090913 Minefield/3.7a1pre.  The fix for bug 215762 probably helped.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsXBLPrototypeBinding::Init]
You need to log in before you can comment on or make changes to this bug.