Scrolling does not want to stop

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: tmeadow, Assigned: mikepinkerton)

Tracking

Details

(Whiteboard: dupme, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050525 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050525 Camino/0.8+

I've seen this quite a few times for a couple of months (but as I recall I don't
remember seeing this with 0.8). I start to select some text on a web page and
move the cursor down, below the window. Camino selects text and scrolls and
scrolls and scrolls until it reaches the end of the page when it finally stops
-- even when I move the cursor to the bottom of the text I'm trying to select or
even if I move it above the selected area.

It seems to happen more often when I'm selecting text and heading south as
opposed to selecting text and moving the cursor up.

Reproducible: Always

Steps to Reproduce:
1. Go to the web page listed above.
2. Click somewhere on the page and move the cursor down below and outside of the
window until text is selected and Camino is scrolling down the page.

Actual Results:  
Camino continues to select text until it reaches the end of the page.

Expected Results:  
Stop at the location where I've moved the cursor.

It does not crash but it is pretty annoying. I switch to Safari to copy the text
I'm interested in when this happens. From what I can tell it tends to happen
mainly on complex pages - I've seen it happen a lot with pages on zdnet.com

Updated

14 years ago
Summary: Scrolling does want to stop → Scrolling does not want to stop
Whiteboard: dupme
Simon: Core bugs Bug 119415 or Bug 29300 (are they dupes of each other)?  There
didn't seem to be anything relevant in Camino itself.
(Assignee)

Comment 2

14 years ago
i saw this recently on the trunk as well, again never with 08x. can we get an
idea of when this regressed?

Comment 3

14 years ago
This WFM - I'm using a double tap to drag with my trackpad, and the page only
scrolls a small amount after releasing, due to the fact the tap isn't released
straight away. Same as Safari.

I have seen this when using Firefox on several XP machines. It happened often
and seemed to be due to the speed of the machines I was using.

Comment 4

14 years ago
Marking WFM I tried everything to reproduce without any luck, perhaps an os bug
or something? No luck for me on 3 different macs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.