Closed Bug 295552 Opened 17 years ago Closed 16 years ago

"Prev visited" and "Next visited" commands to navigate message visitation history (for session)

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 74959

People

(Reporter: jdg, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Thunderbird version 1.0 (20041206)

Please restore the "Next" and "Previous" commands (on the menu bar and via
keyboard equivalents 'n' and 'p') to work as they did in the Netscape
Communicator mail client.  (These take you back and forth through the history of
messages you have previously viewed in this session, analogous to the way that
the "Next" and "Previous" arrows in a browser go through the list of web pages
you have viewed.)

The present functionality of Go -> Next and Go -> Previous (and 'n' and 'p'),
which simply go forward and back one line in the list-of-messages pane, should
be kept available but renamed to "Forward" and "Back" (and 'f' and 'b') as they
were in Communicator.

The removal of this feature was the biggest annoyance in switching from
Communicator to Thunderbird.

Reproducible: Always

Steps to Reproduce:
Related to bug 235666?
Bug 167269 (Seamonkey) also requests a visitation history, altho the shortcut 
keys requested there ("Netscape 4.x") are Alt+LeftArrow and Alt+RightArrow -- 
which are more sensible: that's what the Firefox and Mozilla browsers use to 
move back and forth in *their* histories.

(In reply to comment #0)
> The present functionality of Go -> Next and Go -> Previous (and 'n' and 'p'),
> which simply go forward and back one line in the list-of-messages pane, should
> be kept available but renamed to "Forward" and "Back" (and 'f' and 'b') as
> they were in Communicator.

Your description of the menu and current behavior is not accurate:
Go|Next and Go|Previous are not action items, but submenus, and the text for the 
items is explicit:
  Message  (F / B)
  Unread Message  (N / P)
  Flagged Message  (no shortcut)
  Thread  (T, next only)

So, as you can see, Forward and Back (F and B) already exist.  The difference 
is, F and B move strictly along the list; N and P move to the next/previous 
*unread* message.  The N/P/F/B behavior is taken from the old-time, text-mode 
newsreaders such as rn, nn and tin.
OS: Windows 98 → All
Hardware: PC → All
Summary: Want "Next" and "Previous" commands as in Netscape Communicator (defined by what messages you have viewed in this session) → "Prev visited" and "Next visited" commands to navigate message visitation history (for session)
Version: 1.0 → Trunk
FWIW, I'm currently working on an extension that does exactly this...
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
I still believe this enhancement is needed.  Would someone with the power to
mark a bug as "confirmed" please do so.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is implemented, for TB 2.0.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 74959
You need to log in before you can comment on or make changes to this bug.