All users were logged out of Bugzilla on October 13th, 2018

Text overprints when browsed with large fonts

RESOLVED FIXED in 2.0

Status

RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: jddst19, Assigned: morgamic)

Tracking

unspecified
x86
Windows 2000

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Text overprints when browsed like I browse:

browser.display.screen_resolution: 115
font.minimum-size.x-western: 20

Reproducible: Always

Steps to Reproduce:
1. set font minimum size to 20
2. set display screen resolution to 115 (might not be req'd)
3. browse

Actual Results:  
overprinting

Expected Results:  
No overprinting
OK, since you didn't describe what "overprinting" means to you (i.e. what's
overprinting what on the page) and you didn't include a screenshot, I'm going to
take a wild stab at it based on what I see on the page when I use big fonts.

Do you need the file size and the supported application version numbers?  To me,
the horizontal rule underneath those seems to line up with the bottom of the
graphics, and the graphics don't grow when you up the font size.  So once your
font size is large enough for the first row of text to match the size of those
images, the second row ends up below the horizontal rule and overwrites the
"Last Update" stuff.  Is that what you're seeing?
<div class="iconbar"> appears to have a fixed height of 34 pixels.  This seems
to be the problem.

By the way, I can see this just using Command-Plus to increase the font size on
the fly (I'm on Mac, it's probably Control-Plus or something on Windows)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
Yeah, it sounds like you've got it. It's so tempting to use fixed pixel sizes but for those of us who need 
to pump the font size, it makes the web a little odd, and makes a lot of slick sites look like crapola.

Comment 4

14 years ago
Duplicate of bug 275963 ?
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> Duplicate of bug 275963 ?

i don't think so. This one is about pixel-perfect dimensions being out of whack with egregiously large 
fonts.
ok, I tried fiddling with the HTML locally...  removing the 34px height
attribute results in the entire thing (icon and all) being below the horizontal
rule instead.  So the height is apparently how far above the rule the block is,
and not how tall that <div> is...  weird...

Comment 7

14 years ago
We'll have to bring in SilverOrange when we do 2.0
Target Milestone: 1.0 → 2.0

Comment 8

13 years ago
*** Bug 303346 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
Still valid with AMO 2.0.  
Assignee: Bugzilla-alanjstrBugs → morgamic
QA Contact: mozilla.update → web-ui

Updated

13 years ago
Depends on: 333675
Browsing AMO v3 looks alright to me with a very large font.  Some stuff is pushed around, but it's very readable/usable still.  I'm going to mark this as fixed.  If you can point me to a specific page that still needs work, please reopen.  Thanks.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.