allowing form input fields to exceed specified maxlength by 1 character

RESOLVED DUPLICATE of bug 207623

Status

()

--
minor
RESOLVED DUPLICATE of bug 207623
14 years ago
14 years ago

People

(Reporter: dorlowski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 (ax)

On form pages with multiple input boxes, if you enter the max number of
characters in an input field it is possible, using the tab key and spacebar, to
force the input field to accept one more character than the max length.

Reproducible: Always

Steps to Reproduce:
1. Enter the max character limit in an input box 
2. Move the cursor to a previous input box
3. Press Tab to go to the maxed out input. 
4. Press the Right Arrow key to move to the end of your input.
5. Press the Spacebar.  A space was added.  You can now press backspace and
enter your additional character or just leave the space in. 
Actual Results:  
On most form pages, I receive a truncation warning, since the database or
processor is expecting a max number of characters which doesn't match.

Expected Results:  
Firefox shouldn't allow the extra character to be entered when a user performs
the steps above. It should consistently enforce the form's maxlength.

Using Pinball 0.9.9.3 Theme (though I doubt that matters)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 207623 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.