Adding an additional comment to the first bug succeeds but returns internal error

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: ahn, Unassigned)

Tracking

2.19.3
x86
Windows XP

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When an additional comment is added to the first bug, it succeeds but shows
internal error when trying to retrieve the next bug.  Additional comments added
when there are at least 2 bugs succeeds without error.  I believe the bug is in
process_bug.cgi around line 202 where $next_bug is calculated.  The conditional
"if ($cur >= 0 && $cur < $#bug_list)" should probably be "if ($cur > 0 && $cur <
$#bug_list)" since bug ID's start with 1.

  After a quick look at process_bug.cgi I believe 

Reproducible: Always

Steps to Reproduce:
1. Create brand new bugzilla instance using checksetup.
2. Create a new bug in TestProduct using the initial admin account.
3. Add a comment to the created bug.

Actual Results:  
Step 3.  "Bug processed.  Changes submitted for bug 1." followed by "Internal
Error.  Trying to retrieve bug 2 returned the error NotFound."

Expected Results:  
Step 3.  "Bug processed.  Changes submitted for bug 1." followed by no error
message.
(Reporter)

Updated

14 years ago
Version: unspecified → 2.19.3

Comment 1

14 years ago
I cannot reproduce using a new fresh installation.

Reporter, can you still reproduce using the latest CVS version? If yes, please
reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.