session history isn't case-sensitive

RESOLVED DUPLICATE of bug 99091

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 99091
13 years ago
10 years ago

People

(Reporter: Marc Bejarano, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

URL's are stored in the session history in a case-insensitive manner.  this is
good for the hostname part of the URL, but bad for the rest.  it can keep one
from being able to navigate back to a page they were at previously.

Reproducible: Always

Steps to Reproduce:
1. go to http://en.wikipedia.org/wiki/Pacer
2. click on the link to for the H-bomb-related PACER project to take you to
http://en.wikipedia.org/wiki/PACER_%28document_system%29
3. notice that clicking the back arrow doesn't behave the way you want it to

*** This bug has been marked as a duplicate of 99091 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.