Last Comment Bug 29578 - DND feedback is wrong on linux in the bookmarks panel
: DND feedback is wrong on linux in the bookmarks panel
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Linux
: P3 normal (vote)
: ---
Assigned To: Christopher Blizzard (:blizzard)
: eli goldberg
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-28 16:44 PST by Christopher Blizzard (:blizzard)
Modified: 2000-04-17 13:39 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.05 KB, patch)
2000-02-28 21:46 PST, Christopher Blizzard (:blizzard)
no flags Details | Diff | Splinter Review

Description Christopher Blizzard (:blizzard) 2000-02-28 16:44:18 PST
The DND feedback is wrong in the bookmarks menu in the sidebar.  The problem is
that the drag event is off by the x/y of the position of the window in relation
to it's toplevel window.  I know how to fix it.  I will do so tonight.
Comment 1 Christopher Blizzard (:blizzard) 2000-02-28 21:46:24 PST
Created attachment 5885 [details] [diff] [review]
patch
Comment 2 Christopher Blizzard (:blizzard) 2000-02-28 21:47:14 PST
I've attached a patch to fix the problem.  It still has debugging code in it but
see if it works for you.  If it does, I'll check it in without the debugging
code enabled.
Comment 3 Christopher Blizzard (:blizzard) 2000-02-29 15:37:37 PST
Fix checked in.
Comment 4 Eli Goldberg 2000-02-29 16:54:15 PST
Claudius, would you like to verify this one? If not, pass it back, and I'll do
it for ya.
Comment 5 Christopher Blizzard (:blizzard) 2000-04-17 11:15:52 PDT
Please ignore the spam.  Changing address.
Comment 6 Christopher Blizzard (:blizzard) 2000-04-17 13:39:04 PDT
bustage from my reassign

Note You need to log in before you can comment on or make changes to this bug.