Loses (resets) focused link when going back to a page

VERIFIED DUPLICATE of bug 36539

Status

()

defect
--
minor
VERIFIED DUPLICATE of bug 36539
14 years ago
14 years ago

People

(Reporter: rupeshkguard-firefoxbugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I use keyboard (tab key) to navigate links. I frequently hit tab a bunch of
times to select a link, then hit enter to open in (in the same window/browser
tab), then hit backspace to go back to the original page. So far so good.

Now that I'm back to the original page, I would like to hit tab once to select
the next link. Instead, FF gets amnesia and the tab key starts again from link #1.

IE works as desired - it remembers the selected link if I go back to the page.

Reproducible: Always

Steps to Reproduce:
1. Open any page (call it pageA)
2. Hit tab a few times to select a link (linkB). Hit enter to open the link.
3. Hit backspace to go back to pageA.
4. LinkB should be selected and hitting tab once should take me to the link
right after linkB. Instead, the tab traversal gets reset to the start of page.

Actual Results:  
FF forgets the currently selected link.

Expected Results:  
Should remember the selected link and restart tab traversal with it.

Comment 1

14 years ago
Duplicate of Core bug 36539?
I beleive so. Marking as a dupe of bug 36539.

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.