proportional display of plain text "falls behind" actual text.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: danlaw1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.7 (KHTML, like Gecko) Safari/125.12
Build Identifier: version 1.0 (20041206)

Whenever writing/replying in Thunderbird, the display of text does not "keep up" with the actual typed 
text. The farther, from left to right that you travel, the further off the problem exhibits itself. For 
instance, if I make the page I am writing in, very narrow on my screen, the problem does not occur, or 
does so minimally. If I use the default page width, by the time I have typed to the end of the line I am 
on, I cannot see the end of that line. I have not established exactly how "off" it is, but it is at least a 
word or two.

If I need to edit anywhere from the middle to end of the default page size, there is no way to tell where 
my Thunderbird cursor actually is (it does not necessarily "line up" with the Mac cursor), since it is not 
displaying exactly where I am.  And, the display may show doubling that does not actually exist, or 
other anomolies that, when I resize the page, disappear, and the actual text is displayed. (I hope this 
makes sense.)

I did not see this problem listed, though I may not have understood some of the language used to 
describe the problems others have found. I would call this tracking, but I don't know if that is the 
correct term. I did not see related tracking issues for Mac.

I am using OSX 10.3.8 on a G4 12" Powerbook.

Reproducible: Always

Steps to Reproduce:
1.Start typing either a new note, or a response. 
2. As the cursor continues to the right, the problem gets worse - less and less of what you have typed 
is showing up since the cursor is not "keeping up".
3.
Actual Results:  
the same.

Expected Results:  
I should be able to see each letter/marking as it is typed, like I am doing here. And, if I wish to go back 
within a sentance to edit, I should be able to easily place the cursor where I want it. Unless I condense 
the size (thus creating a narrow text column in which to work) I am not able to tell where the cursor 
actually is - the visual does not match the actual. (unlike how it DOES match as I am now typing this 
response.)

I have been using default settings, no crashing occurs, I have not used unusual settings or made any 
unusual changes that I am aware of. I have checked for viruses/etc. and have detected none, nor have I 
had a history of viruses, etc., on this machine.

If this is only occuring on my machine, I would like to know how I might fix it - I like the software and 
intend to continue using it, but I would prefer a more cooperative cursor.

Comment 1

13 years ago
This happens for me too, on Tiger 10.4.2. I don't know how to avoid or fix it.

Comment 2

13 years ago
Tbird 1.06, OSX 10.4, PBook G4, unable to replicate error. I type email (plain
text) all day and it works just fine.

Do you use plain text or html email? What fonts? Any special language settings?
Any unusual extensions or 3rd party apps that monitor typing in progress?

Sounds like something is sucking up too many cycles. You should open
/Applications/Utilities/Activity Monitor, sort by CPU usage and leave it open
while you type.

Comment 3

13 years ago
Frankie, I think you misunderstand the behavior. First of all, it only happens for me when I set thunderbird 
to use proportional fonts for plain text messages. Anyway, it's not a CPU usage issue. If I click at a certain 
position in the text, then start typing, the text is inserted at a different place on the line.

Comment 4

13 years ago
You didn't say anything about proportional fonts in your original report.
Furthermore, you said you "have been using the default settings", but the
default for plain text is monospace.

Ah well, thanks for the clarification. Afraid I won't be able to help with this
bug. I've locked my copy of Thunderbird into mono plain text so thoroughly, I
don't remember how to get it out.
Summary: cursor and display of text "falls behind" actual text. → proportional display of plain text "falls behind" actual text.

Comment 5

13 years ago
I didn't file the original report. To change to proportional width font, visit Preferences Display tab and click 
"Variable width fonts."
QA Contact: message-compose

Comment 6

12 years ago
(In reply to comment #1)
> This happens for me too, on Tiger 10.4.2. I don't know how to avoid or fix it.
> 

I am experiencing the same problem.  I have a new MacBook Pro, OSX 10.4.9, 2.33 GHz Intel Core 2 Duo, 3 GB RAM, Thunderbird version 2.0.0.4 (20070604).  I am experiencing the problem both in replying to messages and composing new messages.  I do not experience the problem with all fonts.  Although I have not yet tested all fonts, I do consistently and reproducibly experience the problem with Century Gothic (OpenType from Monotype, .ttf, from Windows) and Avenir LT Std 45 Book (OpenType from Linotype, .otf, for OSX).  I do NOT experience any problem with Arial and Helvetica.

I can compose a new message in Century Gothic or Avenir LT Std 45 Book, experience the problem, select all text entered, change the font to Arial or Helvetica, text displays properly, finish the message in Arial or Helvetica without problem, again select all text entered, change the font back to Century Gothic or Avenir LT Std 45 Book, and send the message.  The recipient sees the message formatted as intended.

I hope this is of help.  I'd love to see this problem resolved.


Comment 7

11 years ago
Reproducing the problem:
I believe the problem is to do with dual monitors  (not in mirror mode). Can the users that have reported the bug please confirm? On my machines (I've tried many MacOSX computers with different versions of mozilla and OSX) the problem arises only when I start mozilla or thunderbird  with two monitors and the desktop spanning both screens. Actually it even occurs in text input boxes in firefox (so a gecko thing I guess). The workaround is to switch to mirror mode of the screens when you start thunderbird/mozilla/firefox.

The bug has cropped up a number of times in bugzilla. I imagine the reason that the bug keeps failing to make 'confirmed' status is that the developers aren't using a dual (extended) display, and users don't think of this as part of the necessary behaviour to "reproduce" the bug.

other bugs with similar reported errors:
295852 
292580?
318150 
249849
262078

Comment 8

11 years ago
Created attachment 322041 [details]
about:config page showing non existant fonts in mac

i hope this one helps, i also have a similar problem (more like bug 318150 but for thunderbird)
i found the workaround by making sure the fonts actually exist.
i had this problem because i copied the profile from windows, and therefore some windows fonts are not available in mac (lucida console)

1. go to preferences, advanced, general, config editor
2. filter for x-western
3. makesure the fonts in the bold preferences are valid fonts, in my case, lucida console does not exist in mac.
4. i changed those to be the default value, (right click and reset) or just type courier and it worked fine now
Assignee: mscott → nobody

Comment 9

10 years ago
I also have this problem, but it has just appeared and it does not relate to a recent installation or update of Thunderbird. The cursor appears ahead of where the actual insertion is, about 2, maybe 2.5 spaces difference.
This problem occurs only in Thunderbird. And it is not consistently a problem.

I run: iMac Intel Core 2 Duo, 10.4.11; Firefox 3.0.3; Thunderbird version 2.0.0.17 (20080914)

This issue popped up after running some updates: Firefox x.x.03 and Mac Intel Security 2008-005 + 006, Java for Mac release 7.

I use HTML and have tried both fixed and varied fonts. 
I have tried these fonts: Verdana, helvetica, courier, arial.

Comment 10

9 years ago
I can't reproduce this in 3.0b4, 10.5.8, intel.

Comment 11

9 years ago
I can't reproduce it either now, although I was seeing this before.

For me (and others agreed on one of the other threads) it occurred only when two monitors were connected. Looked as if there was some confusion in gecko (contrary to above reports the problem did also occur in form entry boxes in firefox) about whether to use the screen size or the display size (spanning multiple screens).

But I agree, it seems to have been resolved. I've tried a variety of fonts with two monitor setup and seems fine.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.