Wiz, Outgoing (SMTP) Server text is cropped prematurely.

VERIFIED FIXED in M15

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] fix in hand. w/b minus on 3/3)

(Reporter)

Description

18 years ago
Build 2000-02-28-08M15: Linux 6.0

Overview: Account Wizard's Server dialog has text that is cut on the right 
margin. There is plenty of space for the text to display, it just needs to wrap 
better.

- The paragraph that starts with "For multiple mail accounts, only one outgoing 
server needs to be specified. For most Internet Service Provi", appears on 
one line and then stops, it doesn't continue displaying or wrapping the rest 
of the line. 

- The next paragraph that start with "If you change the account you use to 
connect to the Internet or if you know that you can use your SMTP", appears 
on one line and then stops, it doesn't continue displaying or wrapping the 
rest of the line.
(Reporter)

Updated

18 years ago
Keywords: beta1
QA Contact: lchiang → nbaca

Comment 1

18 years ago
Is this just a display problem?  ...or does the server name get mangled?
Whiteboard: [NEED INFO]
(Assignee)

Comment 2

18 years ago
this is just a layout problem. reassigning to... trudelle? this is an HTML DIV
inside XUL... I'll also CC hyatt

If there's a better tag I should be using, let me know. This is for a long
paragraph that needs to word-wrap, so <text> or <titledbutton> is not
apppropriate.
Assignee: alecf → trudelle
Summary: Wiz, Outgoing (SMTP) Server text is cut → Wiz, Outgoing (SMTP) Server text is cropped prematurely.

Comment 3

18 years ago
I'll let hyatt determine if it is XUL or should go to layout.
Assignee: trudelle → hyatt

Comment 4

18 years ago
Cap the width to make the div wrap.  XUL bug.
Assignee: hyatt → phil

Comment 5

18 years ago
Alecf, did hyatt use enough words for you to understand what he meant? :-)
Assignee: phil → alecf
(Assignee)

Comment 6

18 years ago
hyatt, I assume you mean put some kind of width on the div... I'll try making it
the same width as the IFRAME, but it seems like layout should be doing this
automatically... it actually seems like it's TRYING but there's some rounding
error since it's only cutting of a few characters.
(Assignee)

Comment 7

18 years ago
oh wait
it doesn't wrap either. let me play with this.
(Assignee)

Comment 8

18 years ago
ok, so I don't know why this isn't wrapping, because lots of other divs in this
dialog do. hyatt, any clues? look at aw-server.xul

Comment 9

18 years ago
Putting on PDT- for beta1.
Whiteboard: [NEED INFO] → [PDT-]
(Assignee)

Comment 10

18 years ago
I have a fix which is low risk, and this looks REALLY unprofessional - this
isn't just polishing, this is sand- please try it if you don't believe me...
just follow the creation of an account to the third page.

removing PDT for reeval
Status: NEW → ASSIGNED
Whiteboard: [PDT-] → fix in hand
Target Milestone: M15

Comment 11

18 years ago
and the account setup is one of the first places a new user sees and makes his 
impression of our product.

Comment 12

18 years ago
[PDT+]
Whiteboard: fix in hand → [PDT+] fix in hand
(Assignee)

Comment 13

18 years ago
fix checked in. thanks
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

18 years ago
Build 2000-03-01-08M15: NT4, Mac 8.5.1
Reopen. It's better but not quite right.

1. NT and Mac: A couple of letters are being cropped on the right margin 
referring to "SMTP" and "connect". 
2. NT, Linux and Mac: Also notice that the Netscape graphic in the top right is 
cropped. Not as much on Linux.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 15

18 years ago
Will become PDT- on 3/3
Whiteboard: [PDT+] fix in hand → [PDT+] fix in hand. w/b minus on 3/3
(Assignee)

Comment 16

18 years ago
those are minor details. the major problem has been fixed.... because this is
PDT+, I'm marking this fixed, I can fix the aesthetics of this after beta.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

18 years ago
This is good enough for now so verifying. 
I will look at the Wizard dialogs again after beta.
Status: RESOLVED → VERIFIED
*** Bug 90321 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.