Closing window with cmd-w crashes

VERIFIED DUPLICATE of bug 29410

Status

()

Core
XUL
P3
critical
VERIFIED DUPLICATE of bug 29410
18 years ago
18 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: saari (gone))

Tracking

({crash})

Trunk
PowerPC
Mac System 8.5
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
- launch apprunner, hit cmd-w. 
- watch it crash.

PowerPC access exception at 1458B9F0 
nsXULDocument::HandleDOMEvent(nsIPresContext*, nsEvent*,
 nsIDOMEvent**, unsigned int, nsEventStatus*)+0013C
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  0FD55B0C  
  1092F9C0    PPC  0FD40874  main+001C0
  1092F930    PPC  0FD3F00C  main1(int, char**, nsISplashScreen*)+0072C
  1092F840    PPC  147C9284  nsAppShellService::Run()+00020
  1092F800    PPC  146FAC40  nsAppShell::Run()+00040
  1092F7C0    PPC  146FB454  nsMacMessagePump::DoMessagePump()+00044
  1092F770    PPC  146FB63C  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00070
  1092F720    PPC  146FC1D4  nsMacMessagePump::DoKey(EventRecord&)+00034
  1092F6D0    PPC  146FC644  
nsMacMessagePump::DispatchOSEventToRaptor(EventRecord&, GrafPort
*)+0004C
  1092F680    PPC  146F78A0  nsMacMessageSink::DispatchOSEvent(EventRecord&, 
GrafPort*)+00048
  1092F640    PPC  146F1A0C  nsMacWindow::HandleOSEvent(EventRecord&)+00038
  1092F600    PPC  146F2880  nsMacEventHandler::HandleOSEvent(EventRecord&)+00050
  1092F5B0    PPC  146F3B94  nsMacEventHandler::HandleKeyEvent(EventRecord&)+
00118
  1092F520    PPC  146D4E80  nsWindow::DispatchWindowEvent(nsGUIEvent&)+00028
  1092F4E0    PPC  146D4D88  nsWindow::DispatchEvent(nsGUIEvent*, nsEventStatus&
)+000B8
  1092F490    PPC  143921A0  HandleEvent(nsGUIEvent*)+00064
  1092F440    PPC  1438DB0C  nsViewManager::DispatchEvent(nsGUIEvent*, 
nsEventStatus*)+007AC
  1092F240    PPC  14394C7C  nsView::HandleEvent(nsGUIEvent*, unsigned int, 
nsEventStatus*, i
nt&)+00190
  1092F1C0    PPC  14394C7C  nsView::HandleEvent(nsGUIEvent*, unsigned int, 
nsEventStatus*, i
nt&)+00190
  1092F140    PPC  14394D08  nsView::HandleEvent(nsGUIEvent*, unsigned int, 
nsEventStatus*, i
nt&)+0021C
  1092F0C0    PPC  0F87D8DC  PresShell::HandleEvent(nsIView*, nsGUIEvent*, 
nsEventStatus*)+00
1AC
  1092F030    PPC  0F9D86A0  nsHTMLHtmlElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsI
DOMEvent**, unsigned int, nsEventStatus*)+00040
  1092EFF0    PPC  0FB10578  nsGenericElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsID
OMEvent**, unsigned int, nsEventStatus*)+00188
  1092EF90    PPC  0F8543B0  nsDocument::HandleDOMEvent(nsIPresContext*, nsEvent*
, nsIDOMEven
t**, unsigned int, nsEventStatus*)+00170
  1092EF20    PPC  14879870  GlobalWindowImpl::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsID
OMEvent**, unsigned int, nsEventStatus*)+00274
  1092EE80    PPC  14638520  nsXULElement::HandleChromeEvent(nsIPresContext*, 
nsEvent*, nsIDO
MEvent**, unsigned int, nsEventStatus*)+00044
  1092EE40    PPC  146316F4  nsXULElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsIDOMEv
ent**, unsigned int, nsEventStatus*)+007A4
  1092ECA0    PPC  146316F4  nsXULElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsIDOMEv
ent**, unsigned int, nsEventStatus*)+007A4
  1092EB00    PPC  146316F4  nsXULElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsIDOMEv
ent**, unsigned int, nsEventStatus*)+007A4
  1092E960    PPC  146316F4  nsXULElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsIDOMEv
ent**, unsigned int, nsEventStatus*)+007A4
  1092E7C0    PPC  14631730  nsXULElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsIDOMEv
ent**, unsigned int, nsEventStatus*)+007E0
 Closing log
(Reporter)

Updated

18 years ago
Keywords: beta1, crash

Comment 1

18 years ago
This appears to be a duplicate of bug 29410, which is marked PDT+.

*** This bug has been marked as a duplicate of 29410 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Sorry for the spam, changing QA contact.
QA Contact: paulmac → jrgm

Comment 3

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.