upgraded to java 5.0 and now my browser is crashing

RESOLVED INVALID

Status

defect
--
critical
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: SmplieSum1, Unassigned)

Tracking

({crash, hang})

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

at www.playlink.com.  I play the mahjong quest.  yesterday, I was prompted to
download java 5.o to play the game.  I downloaded and the game loads in a
seperate window as before.  although sometimes with different results.  The real
problem is when I exit the finished game by choosing the "no" tab. 
Before I installed the java the lobby page would reload with the new ratings
from my game session.  
Since I installed the progam the page freezes and doesn't respond.  I receive a
quality feedback window, but when it goes to send the bug, it just hangs and
never makes the connection.  
I love Mozilla, thank you for giving a choice rather than just IE.  

Reproducible: Always

Steps to Reproduce:
1.Load the mahjong game. (it loads in a separate window)
2.play the game, when you're finished, choose "no".  The game window will close. 
3.The browser window with the lobby will then freeze. (it should refresh with
the new rating)

Actual Results:  
the window had a 'not responding' line at the top. 

Expected Results:  
the program should have refreshed the lobby browser window with the new rating
from the game session.
Could you please try this with a new profile
(http://www.mozilla.org/support/firefox/profile) and if still does not work with
a nightly
build(http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/).
Please give some news.
Component: General → Java: OJI
Keywords: crash
Product: Firefox → Core
Version: unspecified → 1.7 Branch
java.com doesn´t always offer the newest, but only major upgrades.
Currently they are serving  jre-1_5_0_02-windows-i586-p.exe, that's Update 2

here you can download Download JRE 5.0 Update 3
http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jre-1.5.0_03-oth-JPR&SiteId=JSC&TransactionId=noreg
http://java.sun.com/j2se/1.5.0/download.jsp

If first link isn´t working, use the second and look at JRE! not J2SE or JDK
JRE 5.0 Update 3
I don't know if this solves the problem.
had a horrible crash using Firefox 1.0.4 and JRE1.5.0_3, but had sametime
Mozilla Suite Trunk open, same site, and some other apps. No talkback, complete
crash/hang, Mozilla Suite Profile crosslinked to win386.swp. I made a backup,
told scandisk hold the profile and remove swap, and after one more scan all was o.k.

I didn´t log in but tried to play as guest. Don´t know how to mark pairs, are
they marked by click, shift-click, ctrl-click, dragging one over another?
I got some points, but didn´t see tiles removed.
Didn´t yet crash with trunk. 
reproducable crash jre1.5.0_03
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050529 Mnenhy/0.7

Steps to repeat:
1. Load http://www.playlink.com/
2. Scroll down, in second column 'Puzzle' click top entry Mah-Jong-Quest
http://playlink.iwin.com/dispatchLobby.do?method=quickmatch&game=mah-jong-solitaire&guest=true
3. A new window opens, click Guest Login
4. Scroll down, click 2nd Tab 'Single Player'
5. Click 1st Tab 'Quick Matches' --> crash

I´ve got now 3 cups of Java in the tray, time to reboot.

MSVCRT.DLL + 0x9abe (0x78009abe)
MSVCRT.DLL + 0x94b6 (0x780094b6)
_destroyJSDObject 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/jsd/jsd_obj.c,
line 110]
js_FinalizeObject 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsobj.c, line
2028]
js_GC 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsgc.c, line
1830]
js_ForceGC 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsgc.c, line
1502]
nsAppStartup::Run 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/components/startup/src/nsAppStartup.cpp,
line 208]
main 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1763]
WinMain 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1787]
KERNEL32.DLL + 0x1b560 (0xbff8b560)
KERNEL32.DLL + 0x1b412 (0xbff8b412)
KERNEL32.DLL + 0x19dd5 (0xbff89dd5)

TB6242857Y
Assignee: nobody → kyle.yuan
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: general → oji
Version: 1.7 Branch → Trunk
TB6243444M on next game
I can play on this Win98SE computer/JRE 1.5.0_03 using Opera 7.54, but I can't
play using Firefox 1.0.4, Firefox Trunk, Mozilla Trunk. If I don´t crash, the
board is loading, but tiles don't get marked when I click on them.
After 2 games in Opera I also had to restart Opera, as the next game wouldn´t load.

Direct link to play:
http://playlink.iwin.com/GameLobby.do?host=games10.nextgame.com&username=guest&password=guest&passid=123&ldir=playlink&type=16041004&fee=10.0&virtual=virtual&pnum=4&title=MahJong%20-%204%20Player%20for%2010PB&option=none&lobby=SPMahJong10_9&game=sp-mahjong&entries=0&method=quickmatch&displayname=Mah-Jong
Severity: normal → critical
Keywords: hang
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050527
Java(TM) 2 Platform Standard Edition 5.0 Update 1
Java Plug-in 1.5.0_01 for Netscape Navigator (DLL Helper)

crashes in my previous comments were seen on Win98SE/JRE 1.5.0_03 on DSL, 80
kbytes/sec, Athlon XP1600, 512 MB 
This working browser is on Win98 (not Win98SE), JRE 1.5.0_01 on ISDN, 8 kbyte/sec

JS console is showing multiple times:

Error: [Exception... "'Permission denied to get property XULElement.accessKey'
when calling method: [nsIDOMXULLabelElement::accessKey]"  nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame ::
http://playlink.iwin.com/GameLobby.do?host=games10.nextgame.com&username=guest&password=guest&passid=123&ldir=playlink&type=16041004&fee=10.0&virtual=virtual&pnum=4&title=MahJong%20-%204%20Player%20for%2010PB&option=none&lobby=SPMahJong10_9&game=sp-mahjong&entries=0&method=quickmatch&displayname=Mah-Jong
:: showApplet :: line 198"  data: no]
Source File:
http://playlink.iwin.com/GameLobby.do?host=games10.nextgame.com&username=guest&password=guest&passid=123&ldir=playlink&type=16041004&fee=10.0&virtual=virtual&pnum=4&title=MahJong%20-%204%20Player%20for%2010PB&option=none&lobby=SPMahJong10_9&game=sp-mahjong&entries=0&method=quickmatch&displayname=Mah-Jong
Line: 198
mass reassign my bugs to Pete Zha.
Assignee: kyle.yuan → pete.zha
(In reply to comment #6)
> wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050527
> Java(TM) 2 Platform Standard Edition 5.0 Update 1
> Java Plug-in 1.5.0_01 for Netscape Navigator (DLL Helper)


Only sometimes WFM. 
Opera seems to be a bit more stable, but after closing the page sometimes I also
crash. Sometimes the page doesn´t repaint when I select two tiles, I´ve got to
minimize and maximize to get a repaint.  JS console of Opera then shows
document.app.repaint() not found or not a function or something like this. If
this is happening, it is throughout the session.
May be dependent on ads, I don´t know.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050605
JRE 1.5.0_01
http://playlink.iwin.com/GameLobby.do?host=games10.nextgame.com&username=guest&password=guest&passid=123&ldir=playlink&type=16041004&fee=10.0&virtual=virtual&pnum=4&title=MahJong%20-%204%20Player%20for%2010PB&option=none&lobby=SPMahJong10_9&game=sp-mahjong&entries=0&method=quickmatch&displayname=Mah-Jong

I'm often crashing on this page, sometimes when loading, sometimes after game
end starting the next. Mostly only DocWatson comes up, rarely Talkback.
Memeory usage is normal, doesn´t grow.
This crash: after 2nd game I started DOM inspector, looked at the page, then
started next game. Repaint after removing a üair of tiles was in the small
comment window to the roight, not in the game area. To see what has ben removed
I had to minimize and restore. 


http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB6422752K
Stack Trace  	
0x00000009
JPINSCP.DLL + 0x395a (0x6d42395a)
PluginWndProc 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginNativeWindowWin.cpp,
line 273]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x242e7 (0xbff942e7)
0x00638bea
Posted file error log from JVM
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050601 Mnenhy/0.7
Java Plug-in 1.5.0_01 for Netscape Navigator (DLL Helper)

I'm using the link from comment 9, as it loads a free game directly.
http://playlink.iwin.com/GameLobby.do?host=games10.nextgame.com&username=guest&password=guest&passid=123&ldir=playlink&type=16041004&fee=10.0&virtual=virtual&pnum=4&title=MahJong%20-%204%20Player%20for%2010PB&option=none&lobby=SPMahJong10_9&game=sp-mahjong&entries=0&method=quickmatch&displayname=Mah-Jong


Win is Win98SE, 512 MB RAM, twice rebooted, crashed multiple times silently or
with talkback, and the JRE produced one snapshot, see attachment.
TB6497886Z, TB6496932H

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB6496932H

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB6497886Z
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050608 Firefox/1.0+
Java Plug-in 1.5.0_03 for Netscape Navigator (DLL Helper)
Win98SE AthlonXP1600+ 512 MB RAM

deinstalled JRE1.5.0_01, installed JRE1.5.0_03, and fresh zips of Firefox and
Mozilla Suite Trunk nightlies. Both crashed multiple times, 
with one talkback from the Suite, and one log from Deerpark.
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB6500947M
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050625
Java(TM) 2 Platform Standard Edition 5.0 Update 4

installed  from http://java.sun.com/j2se/1.5.0/download.jsp
http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jre-1.5.0_04-oth-JPR&SiteId=JSC&TransactionId=noreg

Win98 SP1 on slow Celeron 333 with 128 MB of RAM, installer tells installation
not recommended, recommends at least Win98SE.

tested navigating through the site to the game, and the game link directly.
Normally it was crashing at start, or end, or after a few games in the game.

As I´m the only commenter, I'm closing this bug as wfm. Feel free to reopen if
this page still crashes using JRE 5.0 Update 4
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050626 Firefox/1.0+
Java(TM) 2 Platform Standard Edition 5.0 Update 4 
Win98SE, 512MB Ram, AthlonXP1600+

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB7048386H
Stack Trace  	
JPINSCP.DLL + 0x2a3b (0x6d422a3b)
JPINSCP.DLL + 0x7e8f (0x6d427e8f)
JPINSCP.DLL + 0x8605 (0x6d428605)
0x778b0c24

The page was running very slow, process explorer from sysinternals was updating
maybe all 5 seconds instead of each one. After the crash process explorer was
running normally. There were about 100 MB of RAM free, no memory leak seen.

On my slow Win98 system (1st edition) Update 4 stopped this game crashing,
here on a relatively modern system it is crashing.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050826 SeaMonkey/1.1a
Java(TM) 2 Platform Standard Edition 5.0 Update 4
Win98, 128MB, Celeron 333, ISDN

TB8805465Q
JPINSCP.DLL + 0x2a3b (0x6d422a3b)
JPINSCP.DLL + 0x7e8f (0x6d427e8f)
JPINSCP.DLL + 0x8605 (0x6d428605)
0x778b0c24
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050829 SeaMonkey/1.1a
Java(TM) 2 Platform Standard Edition 5.0 Update 4

played mahjong:
http://playlink.iwin.com/GameLobby.do?host=games10.nextgame.com&username=guest&password=guest&passid=123&ldir=playlink&type=16041004&fee=10.0&virtual=virtual&pnum=4&title=MahJong%20-%204%20Player%20for%2010PB&option=none&lobby=SPMahJong10_9&game=sp-mahjong&entries=0&method=quickmatch&displayname=Mah-Jong
after Game finished, answered 'no' to continue, and loaded heise.de from
bookmarks, opened mail and crashed.

TB8931332M
JPINSCP.DLL + 0x2a93 (0x6d422a93)
JPINSCP.DLL + 0x7e8f (0x6d427e8f)
JPINSCP.DLL + 0x8605 (0x6d428605)
0x778b0c24

Stack Signature from comment 14 (rv:1.9a1) Gecko/20050826
is identical to signature from Bug 270834 comment 7 (rv:1.8b2) Gecko/20050625

Bug 270834 Crash after closing www.hifx.com or Java console in or loading again
after close [@ nsXPCWrappedJSClass::GetInterfaceName ]
Assignee: pete.zha → live-connect
Status: REOPENED → NEW
Component: Java: OJI → Java: Live Connect
QA Contact: oji → pschwartau
Blocks: 353557
No longer blocks: 353557
I'm closing this bug now as the link to the game is lost and I don't want to register to find out if I still could find it somewhere.
Feel free to reopen if you can supply a link where you can see this bug.
Status: NEW → RESOLVED
Closed: 14 years ago13 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.