iframe scroll bar on macosx draws over top of position: absolute elements with higher z-index

RESOLVED DUPLICATE of bug 287385

Status

RESOLVED DUPLICATE of bug 287385
14 years ago
9 years ago

People

(Reporter: desrt, Assigned: jaas)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I think this is new, but sorry if it's a dup.

If you have an iframe in a page that also has an absolutely-positioned element
that overlaps the iframe then the scroll bar of the iframe is incorrectly drawn
over top of the absolutely-positioned element.

This occurs even when the element has a z-index that's higher than that of the
iframe.

This only happens on Mac OS X.  I've checked for myself and it doesn't occur on
Linux.  I've also been told that the problem does not occur on windows.

Reproducible: Always

Comment 1

14 years ago
Looks like bug 287385

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 287385 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.