Closed Bug 295956 Opened 16 years ago Closed 15 years ago

Editing message in drafts folder (with IMAP and multiple profiles) results in error.

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jefdriesen, Assigned: Bienvenu)

References

Details

(Keywords: fixed1.8.0.4, fixed1.8.1)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla Thunderbird version 1.0.2 (20050317)

I have an IMAP mailbox that I access with 2 different computers (home and work).
It works perfectly, except for the drafts folder. I can create a message and
save it to the drafts folder on one computer. But when I want to finish the
message on the other pc, I get the error message "An error occurred while
creating a message compose window. Please try again."

I'm not sure, but I guess it has something to do with the headers X-Identity-Key
and X-Account-Key. When the message is saved to the drafts folder on the server,
these headers are set correctly according to my thunderbird setup on the first
pc. But on the other pc, these values don't make sense anymore. There is no
account associated with the header values of the saved message. Maybe this is
the problem?

And why are these headers necessary for an IMAP account anyway? 

Reproducible: Always

Steps to Reproduce:
Create 2 profiles with thunderbird, each with a different number of accounts (or
different order?). Add the IMAP account to both profiles.

1. Activate the first profile.
2. Create a message and save it to the drafts folder.
3. Switch to the second profile.
4. Try to edit the message in the drafts folder.
Actual Results:  
An error message is displayed with the text "An error occurred while creating a
message compose window. Please try again."

Expected Results:  
Message compose window should open for editing the message in the drafts folder.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
I can confirm (but not er, /CONFIRM/) this problem.  I didn't go as far as Jef
in figuring out why it might be happening, but my symptoms are precisely the same.
Hope that helps it get fixed ..
have either of you tried thunderbird 1.5beta 2?
(In reply to comment #3)
> have either of you tried thunderbird 1.5beta 2?

I'm using a beta version of thunderbird at the moment:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006
Thunderbird/1.4.1 ID:2005100614

However, the problem is not solved in this version. A workaround is to edit the
prefs.js configuration file and make sure all "mail.server.serverx" and 
"mail.identity.idx" do match on both computers (or profiles).
(In reply to comment #4)
I can confirm it's a problem on all versions. Will this be fixed or just best to use the work around.
(In reply to comment #4)
I can confirm it's a problem on all versions. Will this be fixed or just best to use the work around.
*** Bug 328004 has been marked as a duplicate of this bug. ***
Confirming based on report to Bugzilla Japan. 

This bug is problem when accountX in X-Account-Key: is not defined at other PC. 
See Bug 279846 for problem when different mail address is set for accountX in X-Account-Key: at other PC.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Difference between two bug was IDxxx in X-Identity-Key: is defined or not-defined when accountX in X-Account-Key: is defined at both.
does this happen with trunk builds?
Assignee: mscott → bienvenu
Cc-ing to Tabata-san. 

My confirmation is based on test by Tabata-san with "Thunderbird version 1.6a1", Trunk-20050915. (Both Bug 295956 and Bug 279846 were observed.)
Tabata-san, can you test with latest trunk nightly?
I, too, can confirm the behavior.  When editing a draft or template which was created on a different IMAP server (and copied to drafts or templates on the current IMAP server), I see unexpected behavior.

* I'm able to open only one compose window of any draft or template created on the alternate IMAP server.  Subsequent opens return the message "An error occurred while creating a message compose window. Please try again."  Other compose windows seem uneffected.

* If I try to save the message, it either saves back to the alternate IMAP server (instead of the IMAP server which is currently selected) or to the local folders if the alternate IMAP server is removed.

This behavior is exactly the same on Windows and Linux.
the second part of the diff (checking for identityElement.selectedItem) prevents the failure to open the compose window. The first part of the patch handles a case where x-identity-key is set to an invalid value. I haven't looked into the imap case yet - the problem I was able to recreate was when I created a pop3 account, saved a message as a draft in local folders, deleted the pop3 account, and then tried to edit the draft.
Attachment #214488 - Flags: superreview?(mscott)
Attachment #214488 - Flags: superreview?(mscott) → superreview+
I believe this is fixed. Please try tomorrow's build.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1
*** Bug 336078 has been marked as a duplicate of this bug. ***
Comment on attachment 214488 [details] [diff] [review]
fix for failure to open drafts message

this has been on the trunk and 2.0 branch for quite a while...it's very safe, and is mail only.
Attachment #214488 - Flags: approval1.8.0.4?
Attachment #214488 - Flags: approval1.8.0.4? → approval1.8.0.4+
Keywords: fixed1.8.0.4
You need to log in before you can comment on or make changes to this bug.