If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Search web for... doesn't add items to search history

RESOLVED WONTFIX

Status

()

Firefox
Search
--
enhancement
RESOLVED WONTFIX
13 years ago
5 years ago

People

(Reporter: Ivan Ičin, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050527 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050527 Firefox/1.0+

If you use context menu to search web with keyword from selection, then it
should be added to collection of your searches

Reproducible: Always

Steps to Reproduce:
1. Select some text on web page
2. From context menu chose Web Search for...
3. try to search that phrase from search bar

Actual Results:  
the phrase does not appear in dropdown list of collected searches

Expected Results:  
the phrase should appear
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

12 years ago
Changing this to enhancement, and expecting none-machine feedback.
Severity: normal → enhancement
Version: unspecified → 1.5 Branch

Comment 3

12 years ago
When you say "collection of your searches", I assume you mean the autocomplete
data in the search box.  My understanding is that that is treated like a form,
and so unless you actually type in it the data is not the same.  Also, opening a
google page and doing a search doesn't add to the search bar for google - from
the point of view of FF the search boxes aren't the same.
(Reporter)

Comment 4

12 years ago
Exactly. I clearly understand your objections. I also clearly understand that
average user won't understand why it is not possible to do such thing.
Marking INVALID because:
- 1.5 branch is not supported anymore
- comment #3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; sr; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2

What's the difference, nothing is fixed?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Version: 1.5.0.x Branch → 3.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080930093007 Minefield/3.1b1pre ID:

This bug makes sense to me. Highlighting some text, right clicking, and choosing "Search <search engine> for <highlighted term>" is the same as typing text in the Search Bar, so when you search for something using the highlight-and-right-click method it should appear when you're typing in the Search Bar dropdown autocomplete.

Certainly this enhancement request is not INVALID. If anything, it's WONTFIX, but that's a module owner's call.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 3.0 Branch → Trunk
I think we'll WONTFIX this because there's potential for confusion, since the search bar's suggestions are for items that were solely typed into the search bar. It sounds like the potential confusion outweighs any gains.
Status: NEW → RESOLVED
Last Resolved: 9 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.