The Date shows up as the time in messages

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Tommy Harvey, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

You can send yourself a message then just look at the date it does not show up
as the date but the time ?  This is even when you have it set to show the date!
It shows the time NOT the Date!

Reproducible: Always

Steps to Reproduce:
1.Just send yourself a message does it every time
2.Not Date shown in message just the Time
3.
This is not Bug.

That indicates that the Message is from Today and so Tbird displays only the
Time.  If you look at tomorrow at this Message the Date is displayed.

The Date is also in the Message Source (View -> Message Source) like :
Date: Mon, 30 May 2005 17:59:53 +0200

Comment 2

13 years ago
I am actually getting any sent emails are showing in the Sent folder with only
the time showing and not the date.  If I send an email out at all it now gets
only the time added and not the date

Comment 3

13 years ago
Sorry I didn't see the 'further' comments suggesting this is not a bug, but the
fact that Thunderbird does not show *today's* emails, instead it simply shows
the time.  However, once you get to tomorrow! then in fact the date is shown.  I
still think that is a little odd though, and perhaps it should show *todays*
full date and time.

Comment 4

13 years ago
this is by design. You can try changing this behaviour by setting the hidden pref
pref("mail.ui.display.dateformat.today", 2);

here are the range of values for that pref:
http://lxr.mozilla.org/seamonkey/source/intl/locale/idl/nsIScriptableDateFormat.idl#42

in trunk builds of thunderbird, you can use the config editor to add that pref,
tools | options | advanced | config editor. In older builds, you need to
shutdown thunderbird and very carefully edit prefs.js in your user profile dir,
or add the pref to user.js
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.