Mouse Button Hold Causes 90% CPU Use

RESOLVED DUPLICATE of bug 141710

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 141710
13 years ago
13 years ago

People

(Reporter: Ted Pavlic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

I noticed that the slight hum of my laptop changed its tone every time I clicked
and *HELD* my Powerbook's mouse button (to bring up a context menu, for example)
until I released the mouse button. I opened my Activity Monitor to display CPU
useage and noticed that Firefox's CPU useage jumped to 90% EVERY TIME I held my
mouse button down inside a Firefox window. It was as if Firefox was polling for
the mouse button release rather than waiting for an OS X event. Note that this
behavior is not linked to the context menu as it occurs even when there is no
context menu. It occurs every time I click and hold the mouse button.

After further investigation, I found that I have this problem with Firefox,
Thunderbird, and the Mozilla Suite on my Powerbook G4 running OS X 10.4.1 (Tiger). 

I do NOT have this problem with Camino. I also do NOT have this problem with any
other non-Mozilla application that I have tried. 

I do NOT have this problem on Windows machines using Firefox/etc.

I have verified that this problem still exists in the nightly build I downloaded
at 2:00 PM today, Monday, May 30, 2005.

As I mentioned before, I have this problem in Firefox, Thunderbird, and the
Mozilla Suite. I do *NOT* have this problem with Camino. I also do NOT see this
problem in other OS X applications.

Reproducible: Always

Steps to Reproduce:
0. Start the Activity Monitor and search for "Firefox" in order to watch its %CPU.
1. Start Firefox (or Thunderbird or Mozilla Suite, but not Camino)
2. Position Firefox to see the Activity Monitor simultaneously.
3. Click and HOLD the mouse button within any Firefox window (for example, to
bring up a context menu)
Actual Results:  
The %CPU shown in the Activity Monitor quickly rose to 90%.

Expected Results:  
The %CPU should have gone back down to 0% (as Camino and other non-Mozilla
applications do) as it released CPU to the rest of the system and waited for the
mouse release event.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 141710 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.