Previous Session(s) - Auto Reload

RESOLVED DUPLICATE of bug 159357

Status

()

Firefox
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 159357
13 years ago
12 years ago

People

(Reporter: Rick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

This feature I find beneficial in a database viewing tool called DBVisualizer
(http://www.minq.se). In that case, it's a little more simple, because it only
needs to automatically connect to a given TNS, so the user need not to connect
each desired connection automatically. 

Reproducible: Always

Steps to Reproduce:
Since this isn't a bug problem, I'll offer free design advice in a textual
format, I prefer UML diagrams, etc. that I think this could be implemented. Work
with me here, picture it on a current revision. See the 'Expected Results' for
the scenarios.
Actual Results:  
N/A

Expected Results:  
1. Offer an option to allow 'Automatic Reload of Previously Loaded Opened
Sessions (last session only)'.
2. Offer two sub-options (only enabled as checkable, if option 1 is checked):
 a. 'Cache Previously Loaded Sessions (faster reloading sessions)'.
 b. 'Ask User Every Time You Close The Browser'.

Scenario A - 
 Checked Option #1
 Checked Option #2a
 Checked Option #2b

Result Scenario A: Firefox remembers the URLs, caches the pages (not including
forms with sensitive information, this will have to be noted in the help
section) , then PROMPTS the user upon exiting Firefox, if they want to reload
the previous session. If user clicks 'NO', then it defaults to normal Firefox
operation, not reloading the previous session. Else, upon opening Firefox again,
all 'x' tabs are automatically queried, assuming there is an Internet connection. 

Scenario B - 
 Checked Option #1
 UNchecked Option #2a
 Checked Option #2b

Result Scenario B: Firefox remembers the URLs (queries actual website), then
PROMPTS the user upon exiting Firefox, if they want to reload the previous
session. If user clicks 'NO', then it defaults to normal Firefox operation, not
reloading the previous session. Else, upon opening Firefox again, all 'x' tabs
are automatically queried, assuming there is an Internet connection. 

Scenario C - 
 Checked Option #1
 Checked Option #2a
 UNchecked Option #2b

Result Scenario C: Firefox remembers the URLs, caches the pages (not including
forms with sensitive information, this will have to be noted in the help
section) , IGNORES prompting the the user upon exiting Firefox, if they want to
reload the previous session. Upon opening Firefox again, all 'x' tabs are
reloaded automatically, assuming there is an Internet connection.

Scenario D - 
 Checked Option #1
 UNchecked Option #2a
 UNchecked Option #2b

Result Scenario D: Firefox remembers the URLs (queries actual website), IGNORES
prompting the user upon exiting Firefox, if they want to reload the previous
session. Upon opening Firefox again, all 'x' tabs are automatically queried,
assuming there is an Internet connection.

Scenario E - 
 UNchecked Option #1
 UNchecked Option #2a
 UNchecked Option #2b

Result Scenario E: Firefox operates as it normally would. 

This would a nice enhancement or 'workaround', in the event BUG #295982 cannot
be fixed. If BUG #295982 is ran into, a user could simply click these options in
the current session, close the current browser session, and reload all that was
lost in the previous session either due to BUG #295982 or something similar.
You should only report one issue/design idea per bug.

Some of the ideas are simular to bug 159357 (and simular bugs have been duped there)

How is this different to bug 159357?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)

> You should only report one issue/design idea per bug.

I think the two sub-options under the main option go hand-in-hand and separating
the two doesn't seem to make sense, as it's not a complete idea, if it were
submitted separately. By the way, was that in the FAQ?

> Some of the ideas are simular to bug 159357 (and simular bugs have been duped 
> there) How is this different to bug 159357?

I didn't read the entire thread, but the basic point is the same. The only
things that I am not sure is that since I am using a different theme than what
Firefox default is setup, I can only assume that the options presented in bug
159357 are radio buttons. This provides added flexibility to allow the user to
decide that if he/she doesn't want to reload from the previous state, to always
go back to the default. Because, when a new window is open, if it's checked to
go back to the last state, then it would seem to me that the browser would open
the last session's tabs in that new window, when all that was needed was a
single tab in a window. Does that make more sense?

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 159357 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.