Rounding error with position:fixed top:0.5px

RESOLVED FIXED

Status

defect
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: Mook, Unassigned)

Tracking

Trunk
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

14 years ago
A div with position: fixed and top: 0.5px causes text within its border area to
be off by one pixel at certain text zoom levels.  Will attach testcase in a
moment.  (The text being affected is not structually within the div, it just
overlaps visually)

Probably related to tracking bugs bug 134942 and bug 63336

Tested on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050530 Firefox/1.0+ (pacifica, 1.0+_2005053021/1.8b2_2005053021)

Steps to reproduce:
1. Open testcase
2. Change the text zoom level around.

Expected behaviour:
16 straight lines always.  (May be in 5 blocks depending on font)

Actual behaviour:
At some text zoom levels, the right half of some lines may be higher / lower
than the left half by one pixel.
Reporter

Comment 1

14 years ago
Posted file test case
Only the position: and top: CSS rules are necessary to reproduce the bug; the
others are just formatting to make this easier to see.
Reporter

Comment 2

14 years ago
The lines should all be straight (as the top and bottom ones are), but some
lines (e.g. second from the top) is not and has a shift in it.

(Screenshot taken by banana in #firefox, who seems to be running Ubuntu's
Firefox "1.0.2" so it's probably a XP problem.)
Whiteboard: DUPEME

Comment 3

14 years ago
Probably related to 287624.

Confirmed Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050811 Firefox/1.0+ ID:2005081108
Status: UNCONFIRMED → NEW
Depends on: 287624
Ever confirmed: true
No, it's not.
No longer depends on: 287624

Comment 5

14 years ago
WFM :Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1

Bug 317375, comment 132 says that that bug fixed this.
Testcase doesn't work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 ID:2006012405
(back lines are not all lined up at different zoom levels)

Testcase does work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012613
(back lines are lined up at different zoom levels)

--> RESOLVED FIXED (by bug 317375)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Depends on: 317375
Resolution: --- → FIXED
Product: Core → Core Graveyard

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.