Menus appear slightly to the right when close to the left of the screen

VERIFIED DUPLICATE of bug 176767

Status

()

Firefox
Menus
--
trivial
VERIFIED DUPLICATE of bug 176767
13 years ago
8 years ago

People

(Reporter: Daniel Cater, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050528
Firefox/1.0+

When clicking on the File menu, the dropdown menu is off to the right slightly.
I.e. the left of the menu, doesn't line up with the left of the File button. I
think it is about 5 pixels off. This doesn't occur in 1.0.4 at least for me.

All of the other menus line up correctly.
(Reporter)

Comment 1

13 years ago
Created attachment 184917 [details]
Screenshot.

Screenshot showing this bug.

This confirms that it is 5 pixels off.

Comment 2

13 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050529
Firefox/1.0+

Does this also happen in safe mode?
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050529
Firefox/1.0+ ID:2005052914
(Reporter)

Comment 4

13 years ago
Yes it also happens in safe mode, with a brand new profile too.

I filed the bug after 4 people on mozillaZine confirmed it.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050530
Firefox/1.0+ ID:2005053004
I see this issue too. Note, you have to have the browser window maximized for
this to be seen.

Possibley related to bug 296004

Comment 6

13 years ago
See this too now. When did this regress?
Keywords: regression
(Reporter)

Comment 7

13 years ago
Steve: It's not quite that it has to be maximised, but thanks for stating that
because I can now see when this occurs.

Un-maximise the window. and then move it off of the left of the screen until the
Edit menu has the first letter chopped off. Now click the Edit menu; the menu
appears to the right. Same for all of the other menus. If you get it close
enough, you can only offset the menu by 1 or 2 pixels instead of 5.

(Reporter)

Updated

13 years ago
Summary: File menu appears slightly to the right of where it should appear → Menus appear slightly to the right when close to the left of the screen

Comment 8

13 years ago
Seems to be always 5 pixels for me. This regressed quite some time ago. I have a
20050513 trunk build of Thunderbird that exhibits the same problem.

Comment 9

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040210 Firefox/0.8

I see this also on 1.0.4, and even on 0.8. 
So I assume it has always been that way on Firefox
(Reporter)

Comment 10

13 years ago
OK, I feel rather stupid now. Window wasn't maximised when testing in 1.0.4, and
indeed as comment 9 states, it occurs there too!

Removing keyword regression. In that case, I stil think this bug should be
fixed. The File menu just looks odd when it is offset. I think the menus should
act as they do in Internet Explorer when near or off the edge of the screen.

Line up with the button if close to the edge of the screen (like the rest of the
buttons do when fully on-screen.)

Menus should stick to the left of the screen when menu-button is partially
off-screen (like Internet Explorer.)
Keywords: regression
(Reporter)

Comment 11

13 years ago
Created attachment 184921 [details]
Internet Explorer Screenshot.

Screenshot showing what Internet Explorer does. When maximised, the File menu
dropdown lines up with the File button, and when partially off-screen, the
dropdown menu lines up with the edge of the screen.

Comment 12

13 years ago
Not sure why this is marked as NEW, it appears to be an obvious dupe?

*** This bug has been marked as a duplicate of 176767 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.