Closed Bug 296056 Opened 15 years ago Closed 14 years ago

Select with min-width:100% has incorrect width (keywords: size reflow layout)

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mikecaines, Unassigned)

References

Details

(Keywords: testcase, Whiteboard: [reflow-refactor])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050527 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050527 Firefox/1.0+

SELECT elements with min-width:100% are not computing their initial widths
correctly, and are not resizing when certain reflows occurr. I am assuming they
should behave the same as text inputs.

Reproducible: Always

Steps to Reproduce:
Test Case 1 Part A (top) shows three elements with min-width:100% (select, div
input:text).

1. Make sure window is not maximized.
2. Note that all three elements are full width of window.
3. Resize window horizontally.
Actual Results:  
Select does not resize as the other elements do. The select's with seems fixed.

Expected Results:  
Select resizes similar to other elements.

Changing text size via the browser menu forces the select to resize.

Although this testcase does not demonstrate it, I have observed that bringing up
the context menu will force the select to resize also, however this may be a
table reflow bug.

Part B (bottom) has a select in a table. Again the select does not resize, and
when the text size is changed the width is often not truly 100%, there are gaps
on the right side.
Attached file testcase
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531
Confirmed.  The behavior (of testcase part a) is the same at least as far back
as September 2004 builds; so this is not a recent regression.
Part B of the testcase should probably be submitted as a separate bug, and this
testcase minimized.
The first part is probably due to the size caching select does.
Whiteboard: [reflow-refactor]
Keywords: testcase
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

Seems fixed by reflow branch landing
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.