GoDaddy Web Host does not support SVG MIME type

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
14 years ago
4 years ago

People

(Reporter: codedread, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050523 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050523 Firefox/1.0+

GoDaddy is one of the largest web hosts in the U.S.  I asked GoDaddy to support
the SVG MIME type in their web servers, but their response was:

"there has been no announcement about adding support for SVG MIME type or when
it may be added"

They use Apache web servers, so I followed the instructions at
http://wiki.mozilla.org/SVG:MIMEType to update the .htaccess file for my own
website.  However, GoDaddy should support MIME type "image/svg+xml" ubiquitously.


Reproducible: Always

Steps to Reproduce:
1. Attempt to view an SVG site on a GoDaddy website that does not have the above
modifications to the .htaccess file.
2.
3.

Actual Results:  
The SVG source is shown.

Expected Results:  
The SVG image should have been rendered by Mozilla (if it had received its
proper MIME type).

Comment 1

14 years ago
Jeff, as much as I appreciate your position I think this is more of a tech
support issue between you and godaddy. The fact that you can use .htaccess means
this is not even a permanent issue with you.

-> INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Bob, 

I had been exchanging some emails with Jonathan Watt regarding SVG on Mozilla
and when I mentioned this, he asked me to raise a bug here so Moz could help
push the issue.  I'm only doing what I was told ;)

Regards,
Jeff

Comment 3

14 years ago
Jeff, no problem. If you could add Jonathan's email to the cc list, we can
discuss what should be done. 
Bob, I asked Jeff to file this bug because I was under the impression that TE
people are interested in getting ISPs to send the correct HTTP headers for SVG
since we require them. Indeed I closed bug 283620 as invalid (the same issue,
but for comcast), but got my knuckles rapped.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.