Closed Bug 29608 Opened 23 years ago Closed 23 years ago

installing .xpi files no longer generates install.log

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 27488

People

(Reporter: ssu0262, Assigned: dveditz)

Details

This only occurs when installing via the browser.  Installing the .xpi files via 
the windows wizard installer does create an install.log file.

This happens on today's build.

Catheen just mentioned that install.log does get created, but then it gets 
deleted when the installation is done.
on a fresh install, where component.reg has not been created yet, install.log 
will not be created.

However, if you create an empty install.log file, the browser will not delete it 
when it finishes with the .xpi file.
forgot to mention that to recreate this bug, delete the component.reg file.
This sounds similar to Bug 27488.  I will see if I can reproduce this with 
today's build, 2/29/00, and comment here.  Stay tuned!
Build 2000-02-29-09-M15(WIN), 2000-02-29-08-M15(MAC), 2000-02-29-09-M15(LINUX)

Something to add here.  All platforms do not create the install.log withing the 
first session or launching of Seamonkey.

However, Windows does do the actual installation (ie adding a file) whereas Mac 
and Linux do not do any installation.  Everything behaves as expected if the 
user exits and relaunches Seamonkey.

I'm claiming that this is a dupe of Bug 27488.
marking bug as a dup of 27488

*** This bug has been marked as a duplicate of 27488 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.