does not recognize innegularly repeating events

VERIFIED DUPLICATE of bug 275121

Status

Calendar
Internal Components
--
major
VERIFIED DUPLICATE of bug 275121
13 years ago
11 years ago

People

(Reporter: michael vore, Assigned: shaver)

Tracking

Sunbird 0.2
Other
Linux

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Mozilla/Sunbird 0.2

Some events repeat, but are not regular - for example I have an activity that
only happens on the 5th Sunday of the month, so it only happens every few
months.  Also some events happen on a particular date, such as the last day of
the month, luckily I entered it today(May 31), but Sunbird doesn't know about
the last day of the month, but the 31st seems to be recognized as the 30th of
June.  

I have tried to fix the .icl file with 'day=5Su' (well, something like that) but
still the event shows up in all months as the last sunday, quite confusing. 

ICal on the compiled on  Solaris -Sparc did work in the proper fashion, but
Sunbird does not recognize the "Real" Ical files.

thanks
mike

Reproducible: Always

Steps to Reproduce:
1. Enter an event on the 5th sunday of the month
2. Repeating event only gives the option of (in May)  the 29th or the Last Sunday
   but what is needed is a 5th Sunday
3.

Actual Results:  
the event shows up in June

Expected Results:  
Only show the event on the 5th sunday of months that have 5 sundays.

Comment 1

13 years ago
Mike:
    Thanks for the bug report.  I believe your requests have already been
covered by bug 259131, for end of the month repeating, and bug 275121, for '5th
[day of week] of the month' repeating.  Can you please take a look at those bugs
and see if you agree that your report is a duplicate of them?  If so, please
resolve this bug as a duplicate of either.
This looks mostly like 275121, so I'm duping to there, though Michael may also
wish to cc: himself on 259131.

Michael: if you could attach single-entry ICS files to those bugs as test cases,
that would help us test this, and make sure that it's fixed in the next Sunbird
release.

*** This bug has been marked as a duplicate of 275121 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Sunbird 0.2RC2

Updated

11 years ago
Status: RESOLVED → VERIFIED
Version: Sunbird 0.2RC2 → Sunbird 0.2
You need to log in before you can comment on or make changes to this bug.