XPInstall dialog does not show when page on active tab has not fully loaded

RESOLVED DUPLICATE of bug 271567

Status

--
minor
RESOLVED DUPLICATE of bug 271567
13 years ago
3 years ago

People

(Reporter: maxxmozilla, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050530 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050530 Firefox/1.0+

All types of installing extensions does not work in such case beside dropping
the xpi to the EM window (rather obvious).

Reproducible: Always

Steps to Reproduce:
1. Choose a page which takes a while to load.
2. Stop it from loading and try to install the extension (even from the
partially loaded page) or try to install the extension when the page is not yet
fully loaded.

Actual Results:  
The XPInstall dialog does not show.

Expected Results:  
The XPInstall dialog does show.
Now that we support whitelisting (in Firefox, but not Suite) we could change the
code to check the loading status only if whitelisting is turned off (it's there
to prevent abusing install prompts, which have been seen in the wild).

*** This bug has been marked as a duplicate of 271567 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.