Java applets not loading with Fx 1.0.4 and JRE 1.5.0_03

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Jonathan Fitt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 05/15, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

No java applets are functional with my install. I have reinstalled Fx, jre
1.4.2, and jdk 1.5.0_03. Java is functional in IE, and standalone.
I selected Netscape/Mozilla during the custom jre installs, but in the control
panel it is not selected, and if I try and select it I get the "You do not have
permission" error.
I have viewed about:plugins and several Java 1.5.0_03 dlls are displayed, and
java is enabled in my tools->options.


Reproducible: Always

Steps to Reproduce:
1. Try to view any applet
2.
3.

Actual Results:  
Blank space where applet should be

Expected Results:  
Shown the applet

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 306651 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 2

13 years ago
I have installed firefox1.5 and now java applets don't work online, but they do offline..????  

They also work on netscape (7.2) and IE, online, but not on Firefox.

Connection is 'broadband' 2Mb.  Applets also fail on old dialup connection.

Have latest java RTE and have 'fixed' the register as recommended elsewhere.

Getting damned frustrated

Comment 3

13 years ago
(In reply to comment #2)
> I have installed firefox1.5 and now java applets don't work online, but they do
> offline..????  
> 
> They also work on netscape (7.2) and IE, online, but not on Firefox.
> 
> Connection is 'broadband' 2Mb.  Applets also fail on old dialup connection.
> 
> Have latest java RTE and have 'fixed' the register as recommended elsewhere.
> 
> Getting damned frustrated
> 
It seems connected with filters, e.g. adblock extension, etc.

I seem to have fixed the problem by going to extensions/adblock/options/adblock
options and unchecking  obj-tabs   Everything else seems to work now.  Ads are
still blocked, and java applets work as usual.  -ed iglehart


Comment 4

13 years ago
Well, it worked for a few hours and then reverted.  Now I have upgraded the adblock to v.5.2.056+  from http://aasted.org/adblock/viewtopic.php?t=2264 and all seems well.

Comment 5

13 years ago
Same problem here, Win XP Pro with FF 1.04 and then 1.5. Worked with Java 1.4.1, but after updating to latest Java, it ceased functioning in FF, but works fine in IE and Opera. Applet never loads. about:plugins show Java dlls as enabled. It is the same for online or offline applets. There are no extensions that could affect this (I have DOM inspector, Talkback, FlashGot, Image Zoom, ColorZilla, Web Developer, and Net Usage Item). I have since removed the old version of Java, with no effect.
I now use Opera for Internet Banking; it's a very nice browser since v8.5 is now free and every bit as good, if not better, than FireFox.
Is anyone still seeing this issue with Firefox 2.0.0.3 or later and the latest JRE (1.6.0_1, I believe?) using a clean profile?

http://kb.mozillazine.org/Profile_Manager

I have no problem with that configuration and a clean profile.
Whiteboard: CLOSEME - 05/15
Closing this bug as WORKSFORME per comment 6. If you can still reproduce based on comment 6, please comment here and reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.