"New list" window needs much improved usability (drag n' drop, ...)

RESOLVED DUPLICATE of bug 135126

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 135126
13 years ago
12 years ago

People

(Reporter: Markus Lindström, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
The "New list" interface in the Address Book suffers from a critical usability
issue. The current one forces the user to enter the e-mail addresses of all
contacts manually, even though they may be in the Address Book, which is quite
simply unacceptable. Indeed, when the "New list" window is open, the user cannot
interface with the Address Book window behind it, as all widgets appear frozen.
He is thus forced to close the "New list" window to look up adresses, write them
down, then type them in.

By the way, if I hadn't been tipped off by someone, I _never_ would have noticed
that new lists were added as subfolders in the Address Book folder in the left
pane. Users would expect to be able to setup the contents of a new list without
having to physically create it first to then drag contacts to it in the left
pane. The latter behaviour is inconsistent as well, as one can drag a content
into the left pane, but dragging it onto the list item in the right pane doesn't
work.

I have a few ideas in mind about how this could be improved.

1) Allow drag n' dropping from the Address Book window to the New List window.
This is the behaviour I originally expected. Of course, this requires that the
Address Book window doesn't get frozen, so users can manipulate the scrollbar in
it and such. This solution is probably all right for people comfortable with
computers, but just isn't obvious to the average Joe. Still, I guess any
improvement is a welcome one.

2) Explicitly add a way to add present contacts. The Outlook-style "Add/Remove"
interface with two panes is ruthlessly efficient in this regard, as I believe
even the most illiterate computer user can figure out how it works.

3) In contrast to Outlook, do leave the ability to manually add adresses without
having to create contacts explicitly ;-).

4) And finally, I guess making the current behaviour consistent would be nice
too as I said earlier, i.e. allow contacts to be dragged into a list item in the
right pane.

I hope these few suggestions will help you guys make the List usability a lot
better! :-D

Comment 1

13 years ago
In TB 1.0.2 this problem has been partially alleviated.  When you start 
entering a name or e-mail address into an address list, there is a nice auto-
completion feature that gives you a menu of matching entries already in any of 
your address books.

But the feature is broken.  If you accept one of the matching entries, TB 
creates a DUPLICATE of that address in the current address book, and links the 
address list entry to the duplicate, not the original.  So if you try to clean 
up by deleting the duplicate, it removes that item from the address list.

The address list should link to the ORIGINAL address table entry, and not 
create a duplicate.
The problem originally reported in this bug is a result, and therefore duplicate of bug 135126 (and possibly bug 58485).

*** This bug has been marked as a duplicate of 135126 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.