If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mousewheel doesnt change selection in DropDown List

RESOLVED WORKSFORME

Status

()

Core
XUL
--
enhancement
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: u49640, Unassigned)

Tracking

Trunk
x86
Mac System 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+

In MSIE you can switch between the options from a dropdown field my selecting it
and move the mouse wheel up or down. Firefox doesnt.

Reproducible: Always

Steps to Reproduce:
1. goto a page with a Dropdown field
2. select it (but dont open it, just select it)
3. scroll with the mousewheel

Actual Results:  
the Dropdown field doesnt change

Expected Results:  
It should (Like MSIE) change the value to the one directly before/after the
currently selected value.
No it doesn not work like that in IE or Opera
->INVA
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
oh, yes it does work in IE (but not in IE)

you can mark it wontfix, but its not invalid
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 3

13 years ago
> oh, yes it does work in IE (but not in IE)

that should read (but not in Opera)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

13 years ago
> oh, yes it does work in IE (but not in IE)

that should read (but not in Opera)
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Component: General → XP Toolkit/Widgets: Menus
Product: Firefox → Core
QA Contact: general → xptoolkit.menus
Version: unspecified → Trunk

Comment 5

13 years ago
Duplicate of/related to Core bug 62905?

Comment 6

12 years ago
The current behaviour is intentional. The mouse-wheel should not follow keyboard
focus. Use the keyboard arrow keys to change the selection in list controls.
See bug 97283 and bug 251986.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
OS: Windows XP → Mac System 7
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.menus → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.