mozilla active x control 1.77, links with "_blank" do not function

RESOLVED INVALID

Status

Core Graveyard
Embedding: ActiveX Wrapper
--
major
RESOLVED INVALID
13 years ago
6 years ago

People

(Reporter: Julika Burger, Unassigned)

Tracking

1.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

I integrate the Mozilla as an active x control in my application,
the popup blocker is disabled.
I need a html file with a link which opens in a new window
(with the IE Actice X Control this works fine) so I create a link like the
following in my html file:

<a
href="http://www.intel.com/cd/products/services/emea/spa/notebook/centrino/196078.htm"
target="_blank" >
<img src="file:///d:\C_Programme\WLANSniffer\ADCache0.GIF" alt="" border=0 >
</a>

If I open the file in the mozilla browser everything works fine but if I open
the file in my active x control the new browser window do not start.
If I create a link without the part target="_blank" the link is opened in the
same window.
How can I create a link which opens a new browser window in my active x control?
Please can you tell me sone a work arround?
I integrate the active x file with the class webbrowser2 from microsoft and 
change the clsid.

Reproducible: Always

Steps to Reproduce:
1.Create a html file with a link which integrates the part target="_blank"
2.Opens this file in the mozilla active x control 
3.now try to activate the link
=> Nothing is happening
(Reporter)

Updated

13 years ago
Severity: normal → major

Comment 1

13 years ago
This sounds like an extension-related problem and not a bug. Please contact the
extension owner for more support or ask for help at http://forums.mozillazine.org/. 

INVALID
Component: General → Embedding: ActiveX Wrapper
Product: Firefox → Core
Version: unspecified → 1.0 Branch
(Reporter)

Comment 2

13 years ago
Hi,

please can anyone assign this bug to Adam Lock (locka@iol.ie)?
I am the submitter of this bug but I can not change the
state of the bug from unconfirmed to new.


Thanks in advantages
Julika Burger
Assignee: nobody → adamlock
QA Contact: general → dunn5557
QA Contact: dunn5557 → activex

Comment 3

9 years ago
Adam Lock is not reading bugs at the present time. ????

Comment 4

9 years ago
Hi Julika,

This email is waaaaay above my head, wish I could get a better handle on addressing bugs like this....

Mike Doak

Comment 5

7 years ago
The ActiveX embedding API was removed in bug 662023 and friends, making this INVALID.

[Filter bugspam on activexinvalid]
Assignee: adamlock → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Assignee)

Updated

6 years ago
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.