Pref to block Javascript window.close

RESOLVED DUPLICATE of bug 176304

Status

defect
RESOLVED DUPLICATE of bug 176304
14 years ago
14 years ago

People

(Reporter: aaronclawrence, Unassigned)

Tracking

1.7 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
A preference which controls whether Javascript can close windows, to match the
existing prefs for allowing Javascript to open unrequested windows, move/size, etc.

My specific example is for some very stupid sites which have decided that
windows should close when they lose focus. Such as 
http://www.justadventure.com/Previews/TonyTough2/TT2.shtm

Comment 1

14 years ago
There already is a (hidden) pref for this: dom.allow_scripts_to_close_windows

Bug 176304 discusses adding UI for this.

*** This bug has been marked as a duplicate of 176304 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.