Function undefined in NS/Mozilla, but defined in IE, after clicking on "All"

RESOLVED DUPLICATE of bug 114461

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 114461
13 years ago
12 years ago

People

(Reporter: soundsw, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)

NS/Mozilla display the page correctly first, but when you click on "All
Products" (or another product-number range), you get the error that function
dispHTMLCode is undefined.  After such a click, the page is generated by
function dispProdsPage, which begins a new document, complete with the SCRIPT
tag for the external javascript file.  Still, the function is undefined further
down in the code, just after the TABLE tag is initialized.
However, in IE, everything works fine.

Reproducible: Always

Steps to Reproduce:
1. Go to web page
2. Click on "All Products"
3. View error message in the console or a debugger - you will see that
writeHTMLCode is undefined at line 1012, right after the TABLE tag is initialized
4. Note a strange phenomenon, a clue perhaps: If I issue an alert after the
document.write of the BODY tag, NS/Moz work correctly.  You can see this by
viewing http:/www.cloud9sales.com/test/raining.htm, which uses a different js
file, cnsjs.js. The only difference between cnsjs.js and cnsjs_NSMozFail.js is
that the former has the alert in it.
Actual Results:  
The screen is blank except for the background image

Expected Results:  
The page showing all the products should have displayed

Comment 1

13 years ago
*** Bug 296558 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Version: unspecified → 1.7 Branch
Fixed by the checkin for bug 296639.

*** This bug has been marked as a duplicate of 114461 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.